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Was ist SNAP und wie finde ich es?

Die SeNtinel Application Plattform (SNAP)* der ESA ist ein freies Programm, mit dem
Satellitenbilder wie die der Copernicus Sentinel-Satellitenmissionen 1, 2, und 3
betrachtet, bearbeitet und auch analysiert werden kdonnen. Im Vergleich zu
kommerziellen Fernerkundungsprogrammen wie ERDAS und ENVI, ist SNAP Open Source.
Das bringt den entscheidenden Vorteil, denn das Programm kann an die eigenen
Bediirfnisse angepasst und erweitert werden. Ein weiterer Vorteil im Vergleich zu anderen
Geoinformationssystemen wie QGIS ist, dass SNAP fiir Satellitendaten und speziell fiir
die Satelliten der Sentinel-Flotte entwickelt wurde. Es bietet daher weitaus mehr
niitzliche Werkzeuge fiir die Prozessierung von Satellitendaten an, beispielsweise die
Integration verschiedenster Satellitensensoren, die Atmosphadrenkorrektur mit dem
Sen2Cor-Prozessor, die Berechnung von einer Vielzahl an Indizes und
Klassifikationsalgorithmen und spezielle Werkzeuge fiir Radardaten.

Die aktuellen Installationsdateien findest du hier zum Herunterladen:

https://step.esa.int/main/download/snap-download/

Abb. 1
# DOWNLOAD

SNAP Download

Current Version

Das Programm steht ausschlieBlich in englischer Sprache zur Verfiigung. Im Folgenden
werden fiir die SNAP Version 9.0.0 * die hdufig verwendeten Werkzeuge auf Deutsch
beschrieben, die das Arbeiten mit dem Programm erleichtern kdnnen. Grundkenntnisse
der englischen Sprache sind dennoch von Vorteil, besonders wenn weitere Werkzeuge
angewendet werden sollen.


https://step.esa.int/main/download/snap-download/
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Wie funktioniert die grundlegende Bedienung von SNAP?

Das Arbeiten mit SNAP kann zunachst etwas ungewohnt wirken, besonders das Standard-
Datenformat. Zudem bendétigen einige Werkzeuge viel Arbeitsspeicher (RAM). Es sind
einige Softwarefehler und Hiirden bekannt, gerade bei der Installation von externen
Werkzeugen wie Sen2Cor. Im Folgenden wird daher fiir Windows-Computer auf einige
Punkte etwas genauer eingegangen, um das Arbeiten mit SNAP so einfach wie moglich
zu machen.

Bedienoberfldche

Nach der Installation stehen dir zwei verschiedene Anwendungen zur Verfiigung, SNAP
Desktop und SNAP Command Line.

Die Hauptanwendung SNAP Desktop bietet eine grafische Benutzeroberflache.
> Product Explorer (1): zeigt die gedffneten Produkte mit ihren Unterordnern.
> Image View (2): zeigt die gewdhlte Darstellung des Satellitenbildes.

> Navigation Tool Window (3):

> Navigation: Anpassung des Ausschnittes vom Image View, dieser wird als grauer

Kasten angezeigt.

> Colour Manipulation: Anpassung der Darstellung des Satellitenbildes.

> Uncertainty Visualisation: Darstellung der Ungenauigkeiten, beispielsweise

fiir ein Klassifikationsergebnis.

> World View: Lage des Satellitenbildes auf der Weltkugel.

Abb. 2
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Mit SNAP Command-Line kannst du dagegen kommandozeilenbasierte Werkzeuge
ausfiihren.

B SNAP Command-Line

Welcome to the SNAP command-line interface.
The following command-line tools are available:
gpt - Graph Processing Tool
pconvert - Data product conversion and quicklook generation
snap64 - SNAP Desktop launcher
snappy-conf - Configuration tool for the SNAP-Python interface

Typing the name of each tool will output its usage information.

Werkzeuge

Werkzeuge sind erst sichtbar, wenn eine Satellitenszene ausgewahlt wurde /
blau markiert ist (Klick mit Cursor auf eingeladene Szene)

Viele Werkzeuge konnen auf drei verschiedene Wege in SNAP gestartet werden:
1.  Rechtsklick auf die Satellitenszene.
2. Meniisymbol (Anzeige durch Auswahl unter Hauptmendiileiste View).

3. Auswahlim Hauptmendi.

Die Darstellung der Werkzeugfenster kann individuell iiber die Hauptmeniileiste
View > Toolbars angepasst werden. Empfehlenswert ist es, ein Hakchen bei Tool Windows

Zu setzen.

Weitere Werkzeuge konnen durch sogenannte Plugins, also spezielle zusatzliche
Programmerweiterungen, unter Tools » Plugins hinzugefiigt werden.

Arbeiten in Projekten und Sessions

In SNAP Desktop arbeitet man in Projekten und Sessions. Mit einem Projekt als
tibergeordneter Organisationsstufe kannst du verschiedene Sessions und
Satellitenprodukte organisieren. Um ein neues Projekt anzulegen, klicke auf File »

Projects > New project “® , navigiere dann in dem sich o6ffnenden Fenster zum
gewliinschten Speicherort, gib einen Namen (File name) fiir dein Projekt an und klicke auf

Open.
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B snAP - Create Project x| A
bb. 4

Lnoki_n:| SNAP V| B i E-

EB'EI I File name: MeinProjekt| I

Zuetztverw... Fies of toe: | SNAP project fles (=xm) ]

Neben dem Product Explorer 6ffnet sich daraufhin ein neuer Reiter namens Projects, in
dem du die ordnerstruktur des neu angelegten Projektes sehen kannst, das sich so nun
auch im Datei-Explorer wiederfindet. Dort findest du auBerdem eine gleichnamige
Textdatei im XML-Format, die dein Projekt definiert und eine automatisch angelegte
Session-Datei mit der Endung .snap.Du kannst dein Projekt liber File > Projects » Save
Project speichern und iiber File > Projects » Load project zu einem spdteren Zeitpunkt
wieder offnen.

B snee

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help M
BOC LA PIR IO
LEE2Aclio @ IEEN

Manager Projects X -

=-{Z3 MeinProjekt

...[23 ProductSets
(Z3 Graphs | = | MeinProjekt - O x
dl
(23 External Product Links
-..[23 Imported Products - Start Freigeben Ansicht - 0
=-[Z3 Processed Products

.2 calibrated Products « v 4 <« SM.. » MeinP... v | O 2 MeinProjekt durchsuchen
(Z3 Coregistered Products

F

(23 Orthorectified Products Mame Anderungsdatum Typ GroBe
Graphs 17.10.2022 11:40 Dateiordner
Imported Products 17.10.2022 11:40 Dateiordner
Processed Products 17.10.2022 11:40 Dateiordner
= 17.10.2022 11:40 Dateiordner
17.10.2022 11:40 Datei 1KB
i MeinProjekt.session.snap 17.10.2022 11:40 Session file saved ... 1KB

Die Session innerhalb des Projektes definiert alle geoffneten Produkte und
Visualisierungen, einschlie8lich aller hinzugefiigten Ebenen, die du in SNAP gedffnet
hast. Sie wird beim Speichern des Projekts automatisch mit abgespeichert. Du kannst
Sessions aber auch ohne Projekt organisieren und nur liber File » Session > Save bzw.

Open arbeiten, um eine Session so abzuspeichern bzw. eine bereits vorhandene zu 6ffnen.

Um Ordner spdter verschieben zu konnen, ohne dass die Verkniipfungen zu den
Produktpfaden verloren gehen, solltest du die fiir ein Projekt oder eine Session
benotigten Produkte auf derselben Ordnerebene speichern, auf der sich auch die SNAP-
Datei der Session befindet, denn dadurch werden die Dateipfade zu den Produkten als
relative Pfade entfernt. ?
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Datenformate

Das Sentinel-Datenformat SAFE

Die Sentinel-2-Daten werden iiber den Copernicus Open Access Hub 3
(https://scihub.copernicus.eu/) oder den CODE-DE EO Finder * (https://finder.code-
de.org/) standardmafiig im (gezippten) SAFE-Format angeboten, dem ,,Standard-Archiv-
Format fiir Europa“. Sentineldaten im SAFE-Format aus diesen Datenquellen zu benutzen,
ist der einfachste Weg fiir die Weiterverarbeitung mit SNAP.

SAFE unterscheidet sich von vielen anderen gangigen Datenformaten, wie beispiels-
weise GeoTIFF. Das Herzstiick ist die xML-Datei auf der hochsten Ordnerebene namens

MTD_MSIL1C.xml bei Level-1C-Daten und MTD_MSIL2A.xml bei Level-2A-Daten. Diese XML-

Datei enthilt alle Metadaten und wird fiir das Offnen der Satellitenbilder in SNAP
verwendet.

« v 4 <« SNAP > SZA_M018020?..‘ > v « v 4 <« SAPL. » S2A M 20220531... » v
Name - Typ Name - Typ
AUX_DATA Dateiordner AUX_DATA Dateiordner
DATASTRIP Dateiordner DATASTRIP Dateiordner
GRANULE Dateiordner GRANULE Dateiordner
HTML Dateiordner HTML Dateiordner
rep_info Dateiordner rep_info Dateiordner
D INSPIRExmI XML-Dokument D INSPIRE.xmI XML-Dokument
D L2A_Manifestxml XML-Dokument manifestsafe SAFE-Datei
manifest.safe SAFE-Datei D MTD_MSILTC.xml XML-Dokument l
D MTD_MSIL2A.xmI XML-Dokument

S2A_MSIL2A_20180207T104211_N0206_R008_T32U.. XML-Dokument

Die eigentlichen Bilddaten, die mit gangigen Geoinformationssystemen wie QGIS
geoffnet werden kdnnen, liegen als einzelne Spektralbander im JP2-Format im IMG_DATA-

Unterordner. Diesen erreicht man {iber Produktname > GRANULE > ... > IMG_DATA. Bei Level-
2A-Daten enthalt IMG_DATA weitere Unterordner, entsprechend der Auflosung (R10m, R20m
oder R60m Meter).

« v 1 |1 « GRANULE >32UME_AO13733_20180207T104212 > IMG_DATA > R10m v | © £ RIOm durchsuchen
v | S2A_MSIL2A_20180207T104211.N0206_R008_T32UME_20180207T124633.54FE ~  Name Grofe
AUX_DATA ] [2A T32UME 20180207T104211 ACT 10m.jp? 218

> DAIASTRIP ) L2A_T32UME_20180207T10421 114.867 KB

| v | GRANULE | ] (24 T32UME 20180207T10421 113120 KB

v | L2A_T32UME_AD13733_20180207T104212 ] 124 _T32UME_20180207T10421 111.979 KB

AUX_DATA ] 124 _T32UME_20180207T10421 125.889 KB

I v mooam 1 ) L2A_T32UME_20180207T104211_TCI_10m,jp2 182110 KB

| i | ] L2A_T32UME_20180207T104211_WVP_10m,jp2 22512 KB
R20m

R60M .

Abb. 7



https://scihub.copernicus.eu/
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« v 4 1 « GRANULE > 32UPB_A022113_20210531T102618 > IMG_DATA v O | 2 IMG_DATA durchsu..
~ | S2B_MSIL1C_20210531T101559_N0300_R065_T32UPB_20210531T130120 ~  Name GroBe
v | S2B_MSIL1C_20210531T101559_NO300_R065_T32UPB_20210531T130120 SAFE & 3208 20210531T101558 8012 614 KD
AUX_DATA <] T32UPB_20210531T10155_B02,jp2 99.006 KB
5 | DATASTRIP ] T32UPB_20210531T10155,|_B03jp2 107.269 KB
| v GRANULE | 4] T320PB 2021053110155 | BO4,jp2 107.341 KB

_B05jp2 32631 KB
_BO06,jp2 33.004 KB
| BO7jp2 33117 KB

v L1C_T32UPB_AD22113_20210531T102618 a T32UPB_20210531T1015

AUX_DATA a T32UPB_20210531T1015

l IMG_DATA I a T32UPB_20210531T1015

Das SNAP Datenaustausch-Format BEAM-DIMAP

SNAP kann mit einer Vielzahl von Datenformaten und Sensoren umgehen, verwendet aber
fiir die Sentinel Toolbox und die Scientific Tools standardmafig das Austauschformat
BEAM-DIMAP, das den Import von SNAP-Daten in andere Anwendungen erleichtert.

Ein Datenprodukt dieses Formates besteht aus einer Hauptdatei mit der Endung .dim, die
auf XML basiert und die Produkt-Metadaten enthdlt sowie einem zusdtzlichen
Datenordner mit demselben Namen und der Endung .data. Der Ordner enthalt
standardmégig die Bilddaten der einzelnen Spektralbander im IMG-Format (binar), ENVI-
Header-Dateien im HDR-Format (ASCII), die die Bilddaten ENVI-kompatibel machen und
einen Unterordner namens vector_data mit CSV-Dateien, in denen die Geometriedaten

definiert sind. ?

SNAP - O =
« v « SA.. » SM.. » v O 2 SNAP durchsuchen
el
MName Typ Grake
2021_52_1 2} .data Dateiordner |
E 2'021_52_L2I.dim SMAP standard 1/0 file (BEAM-DIMAP format) I 43,640 KB

E12021_S2_L2A dim E3

1 <?2xml version="1.0" encoding="ISO0-8859-1"2> ~
Ed)imap_t)ocument name="2021_L2A.dim">
<Metadata_Id>

<METADATA_ FORMAT version="2.12.1" )DDILP(/HETADATA_E‘ORHAT)I

<METADATA_ PROFILE>BEAM-DATAMODEL-V1< /! METADATA_PROFILE>
- </Metadata_Id>
= <Dataset_Id>
<DATASET_SERIES>BEAM-PRODUCT</DATASET_ SERIES>
g <DATASET NAME>2021_L2A Output Product</DATASET NAME>
10 | | </Dataset_Id>
I1aeH <Dataset_Use>
12 <DATASET_AUTO_GROUPING>
sun:view:quality:ECMWF:tile:detector_footprint:nodata:partially corrected crosstalk:coarse .

oOdoaunmawn

o

eXtensible Markup La length : 46.735.068 lines : 429.457 In:4 Col:66 Pos:168 Windows (CRLF)  UTF-8 INS

Abb. 8

Abb. 10
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Besonderheiten bei Dateien und Ordnern

Zu allererst: Beim Arbeiten mit SNAP solltest du keine Leerzeichen in Anmeldenamen,
Dateien und Ordnern usw. verwenden, denn SNAP kann mit diesen meist nicht umgehen
und einige Prozesse laufen nicht weiter, da sie bei dem Leerzeichen stoppen. Dies kann
argerlich sein, wenn z.B. der Dokumenten-Ordner des Windows-Benutzernamen ein
Leerzeichen enthalt:

falsch: C:\Users\Dein Name\Documents
richtig: C:\Users\DeinName\Documents oder C:\Users\Dein_Name\Documents

Der Ordner fiir den Zwischenspeicher ist meist der Ordner eines Nutzers
(z.B. c:\Users\Erika\.snap) — Im Hauptmenii tber Tools > Options auf dem Reiter

Performance kann der Ordner fiir den Zwischenspeicher cache Path eingesehen werden

(im Ordner des Nutzers ist dieser meist versteckt).

Um Fehlermeldungen zu vermeiden, diirfen im Ordner des Nutzers (z.B. C:\Users\Erika)
und im Dokumente-Ordner des Nutzers (z.B. C:\Users\Erika\Documents) keine Ver-

kniipfungen abgespeichert werden.

Beim Entpacken einer Satellitenszene kann es hilfreich sein, die Datei danach nicht in
einen anderen Ordner zu verschieben, da es sonst passieren kann, dass versteckte
Dateien nicht mitgenommen werden.

Weiterhin ist die generelle Empfehlung, bei Fehlermeldungen SNAP neu zu starten und
erneut den Prozess durchzufiihren. Auch kurzes Warten nach Offnen des Programms
kann dabei helfen, dass das Programm reibungslos lauft.

Sollten wahrend der Nutzung von SNAP Fehlermeldungen oder andere Probleme
jeglicher Art auftauchen, so ist das englischsprachige SNAP Hilfsforum eine gute
Adresse: https://forum.step.esa.int/

11
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Wie lade ich Satelllitendaten von Sentinel-2 in SNAP ein?

Offnen eines Produktes

Auf diesem Weg kannst du Daten in SNAP &ffnen, die lokal auf deiner Festplatte, auf
einem Netzlaufwerk oder einer Cloud gespeichert sind.

Um lange Ladezeiten und unerwartete Fehler zu vermeiden, sollten die Satelliten-
daten am besten lokal gespeichert werden, auch externe Festplatten eignen sich
dafiir.

Das Offnen einer Datei erfolgt tiber das ordner-Symbol & oder iiber die Meniileiste File
> Open Product.... Wahle die Datei aus (beim SAFE-Format die xmL-Datei, beim BEAM-
DIMAP-Format die bIm-Datei) und 6ffne sie mit open (vgl. S. 7, Arbeiten in Projekten und

Sessions).

- Open Produ *
B sNAP - Open Product Abb. 11
Look in: | SIB_MSIL1C_20210531T101559_N0300_RO65_T32UPB_20210531T130120.SAFE v| Bk E-
AUX_DATA Advanced
DATASTRIP
Zuletzt verw... GRAMULE
m bl
peson | MID_wiLiCam |
& 520_M _20ZT0331T101559_N0300_R065_T32UPB_20210531T130120-ql.jpg
Dokumente File name: | ‘
B Files of type: |AJI Hes \,‘ Cancel
Nun erscheint das Produkt im Product Explorer. Uber einen Doppelklick auf den Eintrag
oder Klick auf das Plus-Symbol lassen sich die enthaltenen Produktordner ausklappen.
Product Explorer X | Pixel Info - Abb. 12

=& | [1] S2B_MSIL1C_20210531T101559_N0300_R065_T32UPB_20210531T130120 |
[ C1 Metadata
-3 Vector Data
-3 Tie-Point Grids
E}@ Bands

- sun

G- view

----- B B1(443nm)

----- B8 B2 (490 nm)

----- B8 B3 (560 nm)

----- B B4 (565nm)

----- B es (705 nm)

----- B B6 (740 nm)

12
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Produktdatenbank & Scientific Data Hub

Die Produktdatenbank, in der Meniileiste unter File » Product Library zu finden, hat drei

grundlegende Funktionen.

1.) Sie ist eine Datenbank aller lokal gespeicherten Satellitendaten, mit der anhand der
Metadaten nach Datum, Name, Ort etc. gesucht werden kann, ohne die Daten direkt
offnen zu miissen. Welche deiner lokalen Ordner dafiir genutzt werden, definierst du
unter Repository > All Local Folders. Uber das Plus-Symbol kannst du das gewiinschte
Verzeichnis auswdhlen und mit Select bestatigen. AnschlieBend werden die darin
enthaltenen Produkte eingelesen und in der Produktdatenbank aufgelistet, wenn du
unter Folder den entsprechenden Ordner auswdhlst. Um die Produktliste zu

aktualisieren, musst du ggf. auf das Lupen-Symbo1 klicken.

X &
Abb. 1
. mEmE
Sort By [ProductName | [Ascending v]
kY
Start date [ Lookin: | SNAP v B
End date
[ BEAM-DIMAP .
=T [ - d S2A_MSILZA_20180207T104211_N0206_R008_T32UME_20180207T124633.5AFE v
Atbutes [ 2uetztvem
— I
[ |
Desktop
A== ¥
=& | &
Acacfniest| | DORmE
Dieser PC _
’ Folder name:  C:\sers\anco\Documents\_SAPIENS\SNAP| |
L vl
1

2.) Batch-Processing ¢ : In der Datenbank ausgewéhlte Produkte kénnen in einem Ar-
beitsschritt mit dem Einladen eines Graphen mit den gespeicherten Verarbeitungsschrit-
ten weiterverarbeitet werden (vgl. S. 34, Haufige Arbeitsschritte automatisieren mittels

Graph Builden.

3.) Neue Satellitenszenen kdonnen mit Hilfe des integrierten Scientific Data Hub herunter-
geladen werden. Dafiir miissen zundchst unter Tools > Options > General > Product

Library > Scientific Data Hub iiber das Plus-Symbol die Login-Daten des eigenen

Zugangskontos beim Copernicus Open Access Hub 3 eingegeben werden (https://sci-
hub.copernicus.eu/).



https://scihub.copernicus.eu/
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B options X Abb. 14

. N - - - Q |Filter (Ctrl+F)
Fle @ QB IS

General || Layer Performance WWW Keymap Appearance SI1TBX S2TBX S3TBX

UI Behaviour Geo-Location Image View RGB-Image Profiles i i Masks
Quicklooks Tool Adapter World View GPF Remote File Repositories Product Library Other

Remote Repositories (Data Sources) List Credentials List

Name

Dorthin gelangst du, indem du in der Product Library unter Repository » Scientific Data
Hub auswahlst, deine gewiinschten Such-Parameter einstellst, nach einem Rechtsklick auf
die Karte neben Area of Interest undKlick aufStart Selection mit der linken Maustaste
ein Interessengebiet aufziehst und auf das Lupen-Symbol klickst.

: Product Library X &5 Ab b
.1
Repository Scientific Data Hub v << < 1/24 > >> ? ABD. 15
Account DeinBenutzername « | Products: 20 out of 471 SortBy |ProductName - | [Ascending v]
Mission Sentinel2 S2A_MSIL2A_20210509T103021_N0300_R 108_T32UMB_20210509T133016 A
Sateliite Fenﬁnel-z URL: https://apihub.copernicus.eu/apihub/odata/v 1/Products(2...
Mission: Sentinel2
Sateliite Platform l ™ Acquisition date: 09-05-2021 12:30:21
Start Date 01-05-2021 - Size: 1.09 GB ¥
End Date l:uos-zozz v [l 52A_MSIL2A_20210509T103021_N0300_R108_T32UNA_20210509T 133016
URL: https:/fapihub. icus. ihub/odata oducts(b...
Bk TS Iszmsm < ttps: /fapihub. copernicus.eu/apihub/ /v 1/Pr (b.

Mission: Sentinel2
Acquisition date: 09-05-2021 12:30:21
Size: 1.08 GB

Cloud Cover |20

«

S2A_MSIL2A_20210509T103021_N0300_R 108_T32UNC_20210509T133016

URL: https://apihub.copernicus.eu/apihub/odata/v 1/Products(1...
Mission: Sentinel2

Acquisition date: 09-05-2021 12:30:21

Size: 1.1GB

S2A_MSIL2A_20210509T103021_N0300_R 108_T32UNU_20210509T133016

URL: https://apihub.copernicus.eu/apihub/odata/v 1/Products(c...
Mission: Sentinel2

Acquisition date: 09-05-2021 12:30:21

Size: 733.88 MB

S2A_MSIL2A_20210509T103021_NO300_R 108_T32UNV_20210509T133016

Relative Orbit

l
Orbit Direction |
|

Product Name

UTM Tile

«

Area of Interest

«

(® Timeline
]

li Il.lll..”|l.|||l..
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Uber einen Rechtsklick auf das gewiinschte Suchergebnis, kannst du die gefundene
Szene herunterladen.
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Wie kann ich die Satellitendaten anzeigen lassen?

Einzelbdnder

Du kannst dir einen Grofteil der in deinem Produkt enthaltenen Elemente iiber einen
Doppelklick auf den entsprechenden Eintrag im Product Explorer anzeigen lassen, z.B.
einzelne Bander. Klappe hierfiir im Product Explorer den Ordner Bands unterhalb des

geoffneten Dateinamens auf. Mit Doppelklick auf ein gewahltes Band, hier B4, erscheint

dieses im Image View.

IProduc( Explorer XIPier Info ‘ — @ B4 x|@ @83 x

-8 S2A_MSIL2A_20180207T104211_N0206_R008_T32UME_20180207T1: A
i (O] Metadata
(@2 Index Codings
@@ vector Data
(1 Tie-Point Grids
4+ sun
w3 view
i quality
[ B1(443nm)

Abb. 16

Bandkombinationen

Wahle fiir die visuelle Darstellung das Satellitenbild iiber die Meniileiste window > Open
RGB Image Window aus oder durch Rechtsklick auf die Satellitenszene im Product
Explorer. Voreingestelltes Profil ist Sentinel 2 MSI Natural Colors. Um ein
Echtfarbenbild zu erzeugen, kannst du die Einstellungen so belassen und gleich auf ok
klicken.

[ select RGB-Image Channels ¢ || [1] Sentinel 2 M1 Natural Colors RGB

Abb. 17

Sentinel 2 MSI Natural Colors §v|a it

Red: |B4 v | fane
[] fixed range min max

Green: |B3 V| e
[] fixed range min max

Blue: |B2 | faee

[] fixed range min max

[[] Store RGB channels as virtual bands in current product

@mw

Du kannst aber auch ein anderes Profil auswahlen, z.B. Sentinel 2 MSI Atmospheric

penetration.

15
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BSeIectRGB—ImageChannels X ] [1] Sentinel 2 MSI Atmospheric penetration RGB X —
‘ Abb. 18
Red: |Bl2 v | fsos
[[] fixed range min max
Green: B11l v [ [ses
[] fixed range min max
Blue: BSA v | feee
[[] fixed range min max
[] Store RGB channels as virtual bands in current product
e

Auch individuelle Bandkombination sind moéglich. Stelle dazu iiber die brop-Down-Pfeile

das jeweilige Band fiir den roten, griinen und blauen Kanal ein. Uber die brei-Punkte-

Symbole kannst du noch weitergehende Ausdriicke fiir einen Farbkanal definieren. Deine

Einstellungen kannst du dann iiber das Disketten-Symbol dauerhaft als Profil

abspeichern. Uber das ordner-Symbol kannst du bereits erstellte Profile 6ffnen und iiber

das Miilleimer-Symbol loschen. Standardmaflig werden die Profile unter dem Pfad

C:\Users\Dein_Benutzername\.snap\auxdata\rgb_profiles abgelegt.

Allerdings kannst du nur Bander gleicher Auflosung kombinieren, sonst wird die

Fehlermeldung Referenced rasters are not of the same size ausgegeben, denn die

Bander von Sentinel-2 sind unterschiedlich aufgeldst:

> Badnder 2, 3, 4 und 8 liegen in der héchsten Auflésung von 10 m vor.

> Banders, 6, 7, 8a, 11 und 12 liegen in 20 m Auflésung vor.

> Béander 1, 9 und 10 liegen in 60 m Auflésung vor.

Um die Bander beliebig kombinieren zu kdnnen, miissen sie daher erst neu gesampelt,

also umgerechnet werden (vgl. S. 37, Anpassen der rdumlichen Auflosung (Resampling

Resample).

H Select RGB-Image Channels X H Edit Red Expression X
Profie: Data sources: I Abb- 19
Sentinel 2 MSI Atmospheric penetration (modified) : . e

e-e

Red: |B12 :: e e

[ fixed range min BS ese
Green: BSA :: (@)

e —— - —
Blue: B4 B3 Functioms. ..

[ fixed range min S r—— A

Expressions are valid Show maﬂts.
[] Store RGB channels as virtual bands in current product D:hho‘wbe-cl&omﬁtgrids B Ok, no armors.
Cancel || Help |
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Synchrone Darstellung in mehreren Fenstern

Alle deine Visualisierungen werden als neue Tabs im Image View angelegt und du kannst
sie einzeln anklicken und anzeigen lassen. Hast du mehrere Visualisierungstabs erstellt,
ist es auch moglich, sie gleichzeitig zu betrachten und zu analysieren. Dazu konnen die
Tabs auf verschiedene Weise parallel in Fenstern angezeigt werden, z.B. horizontal.
Hierfiir wahlst du die horizontale Betrachtung iiber das Tile-Horizontally-Symbol m
oder in der Mendiileiste unter windows > Tile horizontally. Die so entstandenen Fenster
kénnen zusatzlich im Navigation Tool Window im Tab Navigation mit Klick auf das
Fenster-Verkniipfungs-Symbol # synchronisiert werden, wodurch sie immer den
gleichen Ausschnitt anzeigen. Aktivierst du das darunter liegende Pfeil-Verkniipfungs-

Symbol %, wird auch dein Maus-Cursor in allen Fenstern synchron angezeigt.

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help Q Search (Ctri+])
SHDE fbd PR AnLOBLL T FRELSe XE v Abb.20
2EZ2Acuoe *xuv[EaED

[ [1] Sentinel 2 MSI Natural Colors RGB ¥ O [[@ [1] Sentinel 2 MSI False-color Infrared RGB X | v O
S A A ) i

e B 7

Product Explorer X l Pixel Info ‘ =)
=& [1] S2A_MSIL2A_20180207T104211_NO206_R008_T32U1 A
- (3 Metadata
@@ Index Codings
@@ Vector Data
(@ (@ Tie-Point Grids
@ Bands
#-@ sun
® D view
-0 quality
[ B1(443.0nm) e
< - >

Naviga... X [Colour Ma...| Uncertaint...| World View | —
2 '3‘!“;.
9
T

P

&
s &
&
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Farbmanipulation und Histogramm

Fiir die Farbdarstellung kann das Histogramm im Navigation Window unter Colour
Manipulation angepasst werden. Sollte das Fenster fehlen, kannst du es {iber das £
Colour-Manipulation-Symbol oder die Menliileiste iiber View > Tool Window > Colour
Manipulation offnen. Jede Anderung, die du hier einstellst, wird dir sofort im Bild

angezeigt.

Die Art der Symbolisierung ist davon abhdngig, wie viele Kandle deine Visualisierung hat.
Ein Mehrkanalraster wie z.B. eine {iber das RGB Image Window visualisierte
Bandkombination hat mehrere Kandle, in diesem Fall 3. Ein Einkanalraster, z.B. ein
Einzelband oder ein Klassifikationsergebnis, das du iiber einen Doppelklick im Product
Explorer visualisiert hast, hat nur 1 Kanal (vgl. S. 15, Wie kann ich die Satellitendaten

anzeigen lassen?).

Farbmanipulation eines Einkanalrasters

Fiir die Darstellung von Einkanalrastern werden drei verschiedene Farb-Editoren
bereitgestellt, mit denen du den Farbverlauf individuell anpassen kannst: Basic, Sliders
und Table. Fast allen gemeinsam sind die vier oberen Bearbeitungsoptionen am rechten
Rand des Colour Manipulation Fensters:

> Uber das Pfeil-Symbol @ (Reset to defaults) kannst du die Farbeinstellungen wieder
in den urspriinglichen Zustand zuriicksetzen.

> Uber das Ubertragungs-Symbol & (Apply to other bands) kannst du deine Farbeinstel-

lung auf andere Einkanalraster iibertragen.

> Uber das ordner-Symbol & (Import colour palette from text file) kannst du eine der
bestehenden Farbpaletten anwenden, die wunter C:\Users\Dein_Benutzer-
name\ .snap\auxdata\color_palettes gespeichert sind.

> Uber das Export-Symbol ® (save) kannst du selbst erstellte Farbpaletten speichern.

Navigation - [1] B4 | Colour Manipula... X | Uncertainty Visuali... |World View - Abb. 21

Editor: (@) Basic () Sliders () Table

Scheme Logyg

- none -— ~

Palette
derived from gray_scale.cpd

I -
[ ] Load exact values Reverse
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Basic: Auswahl eines Schemas oder einer Farbrampe

Wahlst du den Basic-Editor aus, kannst du mit Klick auf den brop-Down-Pfeil einfach eine

der bereits vorgegebenen Farbrampen auswdhlen und als Grundlage fiir weitere
Bearbeitungen in den anderen Editoren nutzen. Du hast auBerdem die Méglichkeit, die
Werte fiir und Maximum anzupassen und dadurch die Grenzen des

Anzeigebereichs zu verandern.

Minimum

Du hast weiterhin die Moglichkeit, ein vordefiniertes Schema anzuwenden, das die
Auswahl von Farbrampe und Wertebereich definiert. Wahle dazu ein Schema iiber den
Drop-Down-Pfeil aus. Diese Schemata sind in der XML-Datei color_palette_schemes.xml

im Ordner C:\Users\DeinName\.snap\auxdata\color_schemes gespeichert. Du kannst sie
mit einem Texteditor 6ffnen und die Parameter anpassen.

jon-[1]84 | Colour x | Uncertainty Visuali... | World View | -

Editor || @ Basic [{) Siders () Table po)

Scheme Logyg

e W

R

paete

derived from X

ciac x

[ Load exact values Reverse
Min: 0.0108515 Max: 0.1552296

From Palette From Data

Slider: Anpassung mit Hilfe des Histogramms

Das Histogramm zeigt die Verteilung der Pixelwerte im Bild an. Optimiere die Anzeige
tiber die Lupen-Symbole, so dass du die wichtigen Bereiche gut erkennen kannst. Die
Warnung Rough statistics! weist {ibrigens darauf hin, dass die statistischen

Informationen des Histogramms nicht vollstandig abgetastet wurden. Klicke darauf, um
die genauen Werte abzubilden.

Durch einen Klick auf den dreieckigen Schieberegler (engl. Slider) kannst du dessen
Farbe verdandern. Mit None erzeugst du Transparenz; unter More findest du weitere Farben,
wobei du die Wahl zwischen HTML Farbnamen (HTML Color Codes), Farbfeldern (Swatches)
und verschiedenen Farbraumen hast. Die Slider lassen sich auch durch Klicken und Ziehen
oder durch Klick auf den zahlenwert und die Eingabe eines neuen Wertes entlang der
Skala verschieben. Durch einen Rechtsklick auf die Farbrampe oder auf einen Slider
kénnen neue Schieberegler fiir weitere Farben des Farbverlaufs hinzugefiigt werden.

Zudem kannst du die Schieberegler automatisch justieren. Sollen alle vorkommenden
Pixelwerte mit dargestellt werden, benutze das 100%-Symbol i+, damit die Schieberegler

den gesamten Wertebereich abdecken. Willst du Extremwerte ausschlieBen, benutze das
20-Symbol =+ oder 3o-Symbol #+, womit nur noch 95,45 % bzw. 99,73 % aller Pixel

beriicksichtigt werden. Uber das Verteilungs-Symbol % werden alle Schieberegler

gleichmaflig zwischen der ersten und letzten Position verteilt. Aulerdem kannst du iiber

Abb. 22
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das Logi-Symbol “* die Schieberegler logarithmisch verteilen, wodurch bei niedrigen
Pixelwerten mehr Farbabstufungen sichtbar werden.

Editor: oassc|© Siders I)Taue

Name: B4 Abb. 23
L'::;t:fEl"‘ E ESelenColoul
g HTML Color Codes  Swatches HSV HSL RGB CMYK
Add new Slider ‘Previea - i Sample Text Sample Text
Sanple Text Sample Text
. | . Sample Text Sample Text
[oc] | conel
Table: Anpassung mittels Tabelle
Im Modus Table sind Farben und Werte {ibersichtlich in Tabellenform aufgelistet. Farben
kannst du per Klick jeweilige Tabellenzelle andern, werte per Doppelklick.
Navigation - ... | Colour M... X | Uncertainty ... | Worid View - Abb. 27
Editor: () Basic () Sliders| @ Table pr)
Logyg
(=)
[i-g
&
Weitere Optionen zur Farbmanipulation
Im unteren Bereich des Colour Manipulation Fensters stehen dir unter More Options
weitere Optionen zur Verfiigung. Hier kannst du im Reiter Brightness/Contrast wie
gewohnt Helligkeit (Brightness) und Kontrast (Contrast) deines Bildes anpassen.
Abb. 25

Brightness/Contrast

-100 0
Contrast m
-100 0
Saturation
-100 0
Reset
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Uber den Reiter Histogram ldsst sich das Histogramm manipulieren. Hier kannst du unter
No-data colour eine Farbe fiir Pixel definieren, die keinen Wert besitzen. Standardmafiig
ist None (transparent) eingestellt. Bei Bedarf kannst du auch unter Histogram matching
das Histogramm anpassen. Setzt du ein Hakchen beiDiscrete colours, werden alle Pixel,

die im Wertebereich zwischen zwei Schiebereglern liegen, in der Farbe des linken
Schiebereglers dargestellt, so dass du das Bild nach Wertebereichen klassifizieren
kannst.

x

bid s Options

Brightness/Contrast

Abb. 26

Farbmanipulation eines Mehrkanalrasters

Fiir Rasterbilder mit separaten RGB-Kandlen bietet das Colour Manipulation Window die
Moglichkeit, jeden Kanal einzeln anzupassen. Das kann z.B. hilfreich sein, wenn die
Farbgebung unnatiirlich wirkt. Durch das Positionieren der Schieberegler bzw. Eingabe

eines Wertes nach Klick auf einen Schiebregler bestimmst du die Wertegrenzen,

innerhalb derer die Pixel eingefdrbt werden sollen.

Navigation - ... ‘ Colour M... X ‘ Uncertainty ...  World View

Abb. 27
(ORed (OGreen (@ Blue

Name: B2

Unit: dI

Min: 1E-4

Max: 0.81
Rough statistics!

Te Ix 0|

=1
=1
X

@rLrll

:

[ &}
N
)
n
N

Im unteren Bereich des Colour Manipulation Window stehen dir unter More Options

wieder weitere Optionen fiir die Bildkorrektur zur Verfiigung. Im Reiter
Brightness/Contrast kannst du Helligkeit (Brightness), Kontrast (Contrast) und auch

Sattigung (Saturation) deines Bildes anpassen. Im Reiter Histogram kannst du auch hier
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tiber No-data colour eine Farbe fiir Pixel ohne Werte definieren und bei Bedarf unter
Histogram matching das Histogramm anpassen. Auch den Gammawert kannst du hier
anpassen (Gamma non-linearity). Er wird verwendet, um ein Bild nicht gleichmagBig,

sondern entsprechend wunseres natiirlichen Farbempfindens aufzuhellen oder
abzudunkeln.

Y

Vv Less Options
Histogram § Brightness/Contrast

Abb. 28

| No-data colour:

| Histogram matching: None v
Source band: B2 v

IGamma non-inearity: 0.8

Pixelinformationen & Spektraldiagramm

Neben dem Product Explorer ist noch ein weiteres Werkzeugfeld zu finden: Pixel Info
zeigt Informationen zu jedem einzelnen Bildpixel, {iber den du deinen Mauszeiger
haltst. Damit kannst du z.B.iiber Latitude und Longitude die geografischen Koordinaten
eines Pixels einsehen oder iiber Scene-x und Scene-Y die Lage des Pixels innerhalb der
Satellitenszene erkennen.

Product Explorer Pixel Info X — || 3] Sentinel 2 MSI Natural Colors RGB X
= Posi
Image-X €485 pixel

Abb. 29

iScene-X €485 pixe

ongi 8728'0S" E|degree

Latitude 53°31'31" Nidegree
p-) -

Map- 5530825.0/m

(=] Time

Date | 2018-02-07|YYYY-MM-DD

[Time (UTC) | 10:42:11:02€ EMHH:MM:5S:mm [AM/PM]

(=1 Bands

B4 | 0.02440d

(=] Tie-Point Grids

tco3 3.6€a42kgm*=-2

towy 0.00825kg m*=-2

ms| 101837.52188Pa

=] Flags

Ein weiteres sehr hilfreiches Werkzeug ist der Spectrum View, zu finden als Spektrem-

Symbol L in der Meniileiste oder unter View > Tool Windows > Optical > Spectrum View,

mit welchem du das Spektralprofil aller Bander eines Pixels ansehen kannst — ndamlich
desjenigen Pixels, iiber den du deinen Mauszeiger hadltst. Durch Bewegen des
Mauszeigers verdndert sich das Spektralprofil entsprechend der Pixelwerte. Diese
Funktion wird durch die Auswahl der Option Show spectrum at cursor position B

aktiviert bzw. deaktiviert.
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Damit die Pixelinformation im Spectrum View nicht wieder verschwindet, sobald
du deinen Mauszeiger auf die Diagrammflache bewegen mdchtest, ziehe den ge-
wiinschten Pixel per Drag & Drop auf die Diagrammflache. Wenn du die Maus-
taste jetzt losldsst, bleibt das Spektrum sichtbar.

Mit dem Spectrum Chooser ¥ lassen sich die angezeigten Bander und Symbole
anpassen. Du kannst die Ansicht vergrofern, indem du mit gehaltener rechter
Maustaste ein Rechteck von der oberen linken Ecke nach unten ziehst, und verkleinern,

indem du ein Rechteck von der rechten unteren Ecke nach oben ziehst. Auch mit einem
Rechtsklick auf die Diagrammflache kannst du den Zoom einstellen. Dariiber ldsst sich

auflerdem die Darstellung des Diagramms anpassen (Properties...) und als PNG-

Bilddatei abspeichern (save as...). Zudem kannst du die Werte mit Export spectra to

text file & als Textdatei exportieren.

Spectrum View X |

Spectrum View

0.45
0.40

0.35
Properties...

s m—

Save as...

0.30

2
020 Print...

015 Zoom In >

0.10 ZoomOut > [F=————g

0.05 Auto Range >
0.00

400 S00 600 700 800 900 1,000 1,100 1,200 1,300 1,400 1,500 1,600 1,700 1,800 1,900 2,000 2,100 2,200
Wavelength (nm)

—f— Bands measured in di

Pins

Mochtest du Pixelwerte oder Spektren bestimmter Orte miteinander vergleichen, kannst
du iiber das Pin-Symbol ** in der Hauptmeniileiste Pins als Marker setzen. Auch deren
Spektren kannst du im Spectrum View betrachten. Uber das Auswahl-Symbol % im
Hauptmenii kannst du einen bzw. mit Hilfe der STRG-Taste auch mehrere Pins anklicken
und auswdhlen. Aktivierst du dann im Spectrum View das Auswahl-Pin-Symbol (Show

Spectra for selected pins) ¢, wird das Spektrum des oder der aktuell ausgewahlten Pins
angezeigt. Um direkt die Spektren aller Pins anzuzeigen, klicke auf das Alle-Pins-Symbol

(Show spectra for all pins) # . Die Pins werden im Vector Data-Ordner der Satellitenszene

angelegt. Wenn die Pins beim nichsten Offnen deines Produktes wieder verfiigbar sein
sollen, gehe mit der rechten Maustaste auf das Produkt im Product Explorer und wahle
Save Product aus.

Um deine Pins zu verwalten, kannst du den Pin Manager “= nutzen. Du findest ihn unter
View > Tool Windows. Hier kannst du iiber die Symbole am rechten Rand neue Pins

Datei importieren (&), exportieren (ﬁ), die Tabelle um Pixelwerte erweitern (7 ),
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ausgewshlte Pin-Daten als tabulator-getrennte Textdatei exportieren (&), sowie auf
einen ausgewihlten Pin zoomen (%) und deine Pins in ein anderes Satellitenprodukt
transferrieren (). AuRerdem kannst du alle Werte eines Pins iiber einen Doppelklick in
das entsprechende Feld auch direkt in der Tabelle anpassen, z.B. Farbe (Color) und Name

(Label).

5 @ (3] S2A_MSIL2A_20180207T 8

# () Metadata
o o Spectrum View Abb_ 31
Spectrum View
DT torrol_ponts
# (3 Te-Pont Grids 14
# (3 Bands
0 Masks 0.3
°
02
0.1
0.0 - . . - - -
500 750 1,000 1,250 1,500 1,750 2,000 2,250
Wavelength (nm)
-~ Acker_Bands ingl _Bands indl —§— _Bands measured in di

Oebaude_Bands measured in di

l {—— Offener Boden_Bands measurad in dl —

| 998108 6646.905  8.244%8
| “S005.613 662.500  8.245626)
| #2400 e671500  8.233400
4982.500| 6681500 8.242169
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Wie erhalte ich atmospharisch korrigierte Satellitendaten?

Wenn fiir eine Analyse mehrere Szenen verwendet werden sollen, ist eine
Atmosphdrenkorrektur notwendig. Sinnvoll ist eine Korrekturimmer, da Satellitenszenen
durch das Herausrechnen von atmosphadrischen Einfliissen klarer erscheinen und
vergleichbarer werden.

Mit Sen2Cor von Level 1C zu Level 2A

SNAP erméglicht die Atmosphdrenkorrektur von Sentinel-2 L1C-Szenen mit Hilfe von
SenzCor 5 (https://step.esa.int/main/third-party-plugins-2/sen2cor/) zum einen als
eigenstdndige Software und zum anderen als Plugin fiir SNAP Desktop.

Seit Mdrz 2018 werden z.B. iiber den CODE-DE Finder * (https://finder.code-de.org/) oder
den Copernicus Open Access Hub3 (https://scihub.copernicus.eu/dhus/#/home) die aus
Level 1C (L1C) hervorgehenden Level-2A-Produkte (L2A) angeboten, die standardméaBig
schon mit dem Sen2Cor-Prozessor korrigiert sind. Fiir neuere Szenen ist eine
Atmospharenkorrektur mit Sen2Cor also nicht notwendig; die Prozessierung der L2A-
Szenen entspricht exakt den Standardeinstellungen von Sen2Cor in SNAP.

Fiir alle anderen Szenen, die vor Madrz 2018 aufgenommen wurden, stehen oft nur die
atmosphdrisch nicht korrigierten Level-1C-Produkte zur Verfiigung. Inzwischen werden
bei CODE-DE auch L2A-Produkte fiir friihere Zeitpunkte nachproduziert. Du hast aber auch
die Moglichkeit, in SNAP mit Sen2Cor selbst atmospharisch korrigierte L2A-Produkte zu
erstellen.

Installieren des Sen2Cor-Plugins

SenzCor (SenzCor v2.8)% kann direkt in SNAP als Plugin hinzugefiigt werden. Du findest

H Plugins X Abb. 32

Updates Avaiable Plugins (19) Downloaded Installed (10) Settings

Check for Newest search:| |
<
il b Sateqery U W Sentinel-2 SEN2COR280 Processor
[] sen2Coral Toobox Kit Module SNAP Supported ... g
[0 snep-zarr SNAP Supported ... C Contributed
] Sentinei-2 Tookox OTB Adspters M... S\AP Suparied .. G || 8 o™ uo
[[] IdePix ProbaV SNAP Supported ... @ || version: 7.0.0
[ IdePix MODIS SNAP Supported ... {fip || Date: 10/22/20
[[] Sentinel-2 SEN2ZTHREE Processor SNAP Supported ... ﬁ Source: SNAP Supported Plugins
[]  SNAP Jython Interface SNAP Supported ... (g Homepage: https: //github.com/senbox-ora/s2thx /s2thx sta-adapters/sen2cor 280
[] IdePix Spot VGT SNAP Supported ... i
[] IdePix Landsat 8 SNAP Supported ... {fiy || Plugin Description
[ 1dePix Virs SNAP Supported ... i
— S - Performs atmospheric correction on Sentinel 2 L 1C products, thereby creating L2A

products using Sen2Cor v02.08.00

¥  Sentinel-2 SEN2COR 280 Processor

] ucr avy I UPpOrted™...

[0 SNAPHU Unwrapping SNAP Supported ... {fip
[] IdePix MERIS SNAP Supported ... i
[] IdePix 52-msI SNAP Supported ... {fip
[] IdePix Core SNAP Supported ... {fp
[[] Sentinel-2 SEN2COR255 Processor ~ SNAP Supported ... g
[0 CHRIS-Box Kit Module SNAP Toolboxes 77

e P
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es im Hauptmenii unter Tools » Plugins. Wenn unter dem Reiter Installed Sen2Cor nicht
angezeigt wird, wahle auf dem Reiter Available Plugins die aktuelle Sen2Cor Version
aus, setze ein Hakchen vor Sentinel-2 SEN2COR 280 Processor und klicke auf Install.

Nun sollte sich das Fenster Plugin Installer Offnen. Folge der Installationsaufforderung
mit Next >, wdhle die Neustart-Option Restart now und bestdtige mit Finish. SNAP

Desktop wird daraufhin neu gestartet und das Plugin sollte nun unter dem Reiter
Installed gelistet sein.

B Plugin Installer X H Plugin Installer X Ab b_
Welcome to the Plugin Installer Restart i to ! llation
The installer will download, verify and then install the selected plugins. Restart application to finish plugin installation.
I T e The Plugin Instaler has successfuly installed the folowing plugins:
Sentinel-2 SEN2COR 280 Processor
Sentinel-2 SEN2COR280 Processor [7.0.0]
l@&zstar‘tNow I
< >
- o (o R
Du kannst SenzCor® jetzt im Hauptmenii unter Tools » Manage External Tools mit Klick
auf sen2Cor und Run oder im Hauptmenii unter Optical > Thematic Land Processing >
Sen2Cor Processor > Sen2Cor280 ausfiihren. Es empfiehlt sich allgemein erstere Variante
zu wahlen, da hier sichergestellt werden kann, dass Sen2Cor richtig geladen wurde.
-BclemalTuuls ><| Abb. 34

Vector Raster Optical Radar Tools Window Help Pdmt:rslocaﬁon [C: \Users\anco\, snap‘auxdata\tool-adapters

GCP B{ 228 External Tools
6 e e o s ¢ Metadata

v

HE. 1

| Attach Pixel Geo-Coding...

Detach Pixel Geo-Coding...

GraphBuilder

i d

Batch Processing

Manage External Tools

Plugins

Options

Remote execution

[~ ) &~ [

Ein Klick auf Run sollte die Prozessierung starten. In manchen Fallen funktioniert Sen2Cor

jetzt jedoch noch nicht und es kommt zu einer Fehlermeldung, wenn die erste L1C-Szene
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prozessiert werden soll, z.B. wenn mit der Methode Tools » Manage External Tools ein

orangefarbenes Ausrufezeichen statt eines griinen Hiakchens bei Status angezeigt wurde.

B senacor X Abb. 35
File Help
Source Product
Source product:
[1] S2B_MSIL1C_20210531T101559_N0300_R065_T32UPB_20210531T130120 "
Wahle also unter dem Reiter Processing Parameters das Hikchen bei Display execution
output, um mogliche Fehlermeldungen sehen zu konnen und klicke Run.
B senacor X Abb 36
File Help ’
jfs] Paramehersl Processing Parameters I
.
[] Seene only -
Resolution: &0 o
— Y]
A
v
Run Close Help
Nun kommt die Fehlermeldung, dass ein Dateipfad bzw. Ordner nicht existiert, dieser
muss erst noch erstellt werden. Klicke hierzu ok.
E Abb. 37
File Help
1/ Parameters | Proce=q B snap - waming X
Display execution outy ! Before executing the tool, please correct the errors below:
[ scene only Path does not exist: 'C:\Users\anco\.snap\auxdata\5en2Cor-02.08.00-winb\L2A_Process.bat' =
Resolution: Working path does not exist: 'C:\Users\anco\.snap\aux data\5en2Cor-02.08.00-wing4" i

B
I L

Daraufhin 6ffnet sich automatisch das Fenster mit den Eigenschaften des Sen2Cor280-
Operators und du wirst, evtl. nach kurzer Wartezeit, in einem weiteren Fenster gefragt,
ob du ein SNAP Paket bundle herunterladen méchtest. Klicke hier auf ves.
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B seracor ®
File Help Abb' 8
/O Parameters| Processing Parameters ¥ snap - Bundle Available X
Display execution output =
I-ﬂ A bundle has been configured for this adapter. "
D Scene only Do you want to proceed with bundle download/installation?
Resolution: ] n P v
—_ B F ]

Run Close Help

Nun sollte in der Fuf3zeile von SNAP Desktop ein Fortschrittsbalken zu sehen sein.

Instaling buncie [ 19% | | Abb.39
Wenn der Download abgeschlossen ist, erscheint wieder ein neues Fenster mit der
Information, wo das Paket installiert wurde. SchlieBe es mit oK. SchlieRe im Anschluss
auch das Fenster mit den Eigenschaften des Sen2Cor280-Operators mit 0k.
B sen2corze0 X Abb. 40
Operator Descriptor Bundled Binaries
Windows Bundie | Linux Bunde | MacOSX Bundie |
Configuration Parameters
Type: Zip archive ~
e Location: (") LocAL (® REMOTE
Operator Parameters Source File:
System Variables URL: http://step.esa.int/thirdparties /sen2cor /2. 8.0/Sen2Cor-02.08.00-win64.zip
i Arguments:
gmndledB'na'ies i
- Target Folder: | gUISERPROFILE/. snap/auxdata

Refiectin Variable: |sen2cOR28_BIN ~

B SNAP - Information X

o Bundle was installed in location:

C:\Users\Shadow\.snap\auxdata\Sen2Cor-02.08.00-win64

o

Export as Module E Cancel Help

Der Status unter Tools > Manage External Tools Sollte nun ein griines Hakchen anzeigen.
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H External Tools > Abb. 41
Emters location ‘C: \Wsers\anco\,snap\auxdata\tool-adapters ||
Status | Alias Description Ed
w’ [Sen2Cor280 |5en2tor Atmospheric Correction Processor Ej

Ausfiihren des Sen2Cor-Plugins

Offne das Sen2-Cor-Plugin 5 am besten immer iiber Tools » Manage External Tools »
Sen2Cor und Run. Um das Werkzeug zu benutzen, musst du im Reiter |/O Parameters unter
Source Product ein Sentinel-2 L1C-Produkt auswdhlen. Produkte, die bereits in deinem
aktuellen SNAP-Projekt eingeladen sind, kannst du iiber einen Klick auf das brop-Down-
Symbol auswadhlen. Alternativ kannst du iiber das 3-Punkte-Symbol auch eine Datenquelle

auBBerhalb deines Projektes definieren.

B senacor X Abb. 42

File Help

:1/0 Parameters 2 processing Parameters

Source Product

Source E
[1] S2B_MSIL1C_20210531T101559_N0300_R065_T32UPB_20210531T130120 v

[Ren |[ Qo |[ teb |

Zum Offnen in SNAP eignet sich die xML-Datei auf oberster Ebene (vgl. S. 12, Offnen eines

Produktes).

l Select Source Product X Ab b
Lookiin: | 52B_MSIL1C_20210531T101559_N0300_R065_T32UPB_20210531T 130120, SAFE V| [ e
AUX_DATA
%ﬂ DATASTRIP
Zuletzt verw... GRANULE
[ INSPIRExmi
- [ ] manifest.safe
Desktop IL1C x
[w] 52B_MSIL1C_20210531T101559_N0300_R065_T32UPB_20210531T130120-qljpg
Dokumente
- =)
! Files of type: | All Files v‘ Cancel

Im Reiter Processing Parameters solltest du immer das Hiakchen bei Display execution
output setzen, um maogliche Fehlermeldungen einsehen zu kdnnen. Unter Resolution

kannst du aufRerdem die rdaumliche Auflosung wahlen. In Foren wird berichtet, dass die
Wahl von 10 Metern oft kein giiltiges Ergebnis liefert. Alternativ ist daher ALL zu wahlen,

dadurch werden alle verfiigbaren raumlichen Auflésungen prozessiert.




SATELLITENDATEN PROZESSIEREN
— DIE SENTINEL-ANWENDUNGS-PLATTFORM SNAP

B senacor X Abb. 44

File Help

1/0 Paametersl Processing Parameters I

I [/] Display execution output I
~

[] Scene onl
[ )
Resolution: &0 V)
| J
Cronly 10
D 20

L2A_GIPP file ==
(Fa fle s selected,
the parameters below

a1 2L .Y

Alle weiteren Parameter wurden aus den Metadaten der Satellitenszene eingelesen und
sollten, sofern ein L2A-Produkt entstehen soll, nicht weiter verdandert werden.

Bei erneutem Klick auf Run startet nun die Ausfiihrung des Werkzeugs.

B senacor X Abb. 45
File Help
Source product: B senecor X
Starting tool execution » | EI

|[1] $28_MSIL1C_20210531T1015!
0%

==

Nach erfolgreichem Abschluss der Prozessierung dffnet sich ein Info-Fenster, das du mit
oK schlief’en kannst. Das Ergebnis erscheint als Output Product im Product Explorer.

| Product Explorer X | Pixel Info [ - Abb. 46
+ 1] 528 1C_20210531T 101559_N0300_R065_T32UPB_20210531T130120 ABD- 46
& [2] Output Product

B sNAP - sEN2COR X

(é The target product has successfully been created and opened in SNAP.

Actual processing of source to target data will be performed only on demand,
for example, if the target product is saved or an image view is opened.

[[] Don't show this message anymore.;

-

Das neue L2A-Produkt wird im selben Ordner wie der L1C-Quelldatensatz gespei-
chert.
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Hilfe bei Fehlermeldungen von Sen2Cor

Leider ist SenzCor® aktuell immer noch instabil und Probleme bei der Installation kénnen
auftreten. Daher gibt es hier einige Hilfestellungen, das externe Plugin erfolgreich
auszufiihren, falls es zu Fehlermeldungen kommt.

Haufige Fehler

Allgemein gilt, keine Leerzeichen in Datei- und Ordnernamen zu verwenden und es kann
helfen, das Programm neu zu starten, falls Sen2Cor unter Manage External Tools hicht
erscheint. Zudem kann es in einigen Fallen hilfreich sein, die Sentinel-2-Szene noch
einmal zu entpacken und nicht zu verschieben (vgl. S. 11, bei Dateien und Ordner).

Fehlermeldungen anzeigen lassen

Um mogliche Fehlermeldungen immer anzeigen zu lassen, setze im Sen2Cor-Plugin unter

Processing Parameters ein Hikchen bei Display execution output.

B senzcor X Abb. 47

File Help

1o Paramehersl Processing Parameters I

ﬁ

[ 5cene only

Resolution: 60 o

Step-Forum

Hilfe findest du auch im step-Forum (https://forum.step.esa.int). Dort kannst du durch
Einkopieren einer Fehlermeldung in die Suchleiste Losungen finden.

s o o con ERVEE O | 45

I [search E I

er launches full page search

Dear SNAP users,

‘We would love to have your feedback on your SNAP experience.

It would help us to know which are the things that should be improved and taken into consideration for the future, so that you will be satisfied when using SNAP.
Please take an anonymous survey in order to help us helping you:

SNAP User Survey

Many thanks from SNAP Team!

Viele Informationen zur Fehlerbehebung in diesem Kapitel stammen aus dem
SNAP-Diskussionsforum step zum Thema der Sen2Cor-Installation:

https://forum.step.esa.int/t/sen2cor-detailled-instructions/8659/2
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Neuinstallation

Falls Sen2Cor auch nach mehrmaligem Neustart und Wartezeit im Hauptmenii unter Tools
> Manage External Tools nicht aufgelistet oder nicht gestartet werden kann oder der

Prozess nicht richtig durchgefiihrt wird (leere Ordner in der L2A-Datei, Abbruch der
Atmosphdrenkorrektur etc.), kann eine Neuinstallation von Sen2Cor das Problem in den
meisten Fallen beheben.

Deinstalliere hierfiir zuerst im Hauptmenii unter Tools > Plugins > Installed den

Sentinel-2 SEN2COR280 Processor mit Uninstall.

. Plugins X Ab b
Updates  Avalable Plugins (18) Downloaded| Installed (11) lsetting
Search: |
<
i e S A% M Sentinel-2 SEN2COR280 Processor

Intent API Libraries (V]

RCP Platform RCP Platform o Version: 7.0.0

SNAP Desktop Rich Client Platform  SNAP Core (V] Source: SNAP Supported Plugins

= e : Plugin Description
[J PROBA-V Toolbox Kit Module SNAP Toolboxes @ | |Performs atmospheric correction on Sentinel 2L 1C products, thereby creating L2A
[] Radarsat Polarimetric Toolkit Module ~ SNAP Toolboxes @ ||products using Sen2Cor v02.08.00
[] smoSs-Box Kit Module SNAP Toolboxes (V]
[J sentinel-3 Toolbox Kit Module SNAP Toolboxes @
[] Sentinel-2 Toolbox Kit Module SNAP Toolboxes Q

Losche als ndchstes folgende Sen2Cor-0rdner aus deinem Verzeichnis:

> C:\Users\Dein_Benutzername\Documents\sen2cor

> C:\Users\Dein_Benutzername\.snap\auxdata\Sen2Cor-02.08.00-win64

Sollte der Ordner versteckt angelegt sein, gib am besten den Dateipfad in den Datei-
Explorer ein und gehe eine Ebene héher, um den Ordner zu [6schen.

Nun kannst du das Sen2Cor-Plugin wieder neu installieren (vgl. S.25 £., Installieren des

Senz2Cor-Plugins).
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Alternative Atmosphdrenkorrektur-Prozessoren

Fiir Deutschland werden alternativ noch weitere atmospharisch korrigierte Produkte iiber
die Plattform CODE-DE EO Finder “ (https://finder.code-de.org/) unter Kollektion >

Sentinel-2 > Processing Level = Level 2A > Product Type kostenlos zum Download
bereitgestellt:

> L2A MAJA: MAJA (Weiterentwicklung von MACCS) ©

> L2A FORCE: FORCE”

SE482» [ NDER DI Anmelden [ hire ] Abb. 50

Leeds

Sheffield
ol
England

Processing Level:
i S SUCHERGEBNISSE

Relative Orbit Name Datumder Aufnahme ~ ~ Datum der Verbffen... W...
Number:

Mission TakelD:

Billed: Free

—

Du kannst also auch die Daten auf der CODE-DE Plattform mit diesen alternativen
Atmosphdrenmodellen prozessieren lassen und mit den daraus entstandenen L2A-
Produkten in SNAP weiterarbeiten.

FORCE 7 und danach MAJA° schneiden in vielen Gebieten bei der Wolkenmasken als auch
die Atmospharenkorrektur besser ab als Sen2Cor. Einen Vergleich verschiedener Atmo-
sphéarenkorrekturen von 2018 findest du in Doxan/ et al. ®

In ariden Gebieten / hellen Oberflachen haben alle Methoden ihre Schwierigkeiten,
FORCE nutzt neben dunklen Vegetationsflaichen auch Wasserflachen zur Aerosol-Ab-
schatzung und kann daher hier evtl. bessere Ergebnisse liefern. Unabhdngig davon ha-
ben Aerosol-bedingte Streueffekte aber auch auf hellen Flachen den kleinsten Einfluss.

Bei  Zeitreihenanalysen sollte der verwendete  Prozessor  zur
Atmosphdrenkorrektur fiir die Szenen immer identisch sein.

Mehr Informationen zur Atmosphdrenkorrektur, den verschiedenen Produktlevels und
der Prozessierung auf CODE-DE findest du in unserem SAPIENS-Handbuch Passende
Satellitendaten finden — Das Datenportal CODE-DE °.
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Wie kann ich Satellitendaten vorverarbeiten?

Im Folgenden werden haufige Standard-Schritte zur Vorprozessierung von
Satellitendaten in SNAP beschrieben. Dabei werden alle Werkzeuge einmal als
Einzelprozessierung beschrieben und einmal, wie man sie im Graph Builder einbindet.

Haufige Arbeitsschritte automatisieren mittels Graph Builder

Der Graph Builder hilft dir dabei, haufig ausgefiihrte Prozessierungen zu
automatisieren. Du kannst damit eine ganze Kette verschiedener
Prozessierungsschritte definieren, abspeichern und bei Bedarf erneut
einladen und ablaufen lassen. Einige Einstellungsmoglichkeiten, die dir bei
Einzelprozessierungs-Werkzeugen zur Verfiigung stehen, finden sich im Graph
Builder allerdings nicht wieder.

Bei der Bearbeitung von Satellitendaten folgen hdufig mehrere Arbeitsschritte auf-
einander, oft mit Zwischenergebnissen, die nur tempordr benétigt werden. Dazu kommt,
dass grundlegende Arbeitsschritte oft wiederholt werden miissen, z.B. wenn die zeitliche
Verdanderung eines Gebietes untersucht werden soll und hierfiir die einzelnen Satelliten-
bilder auf gleiche Weise prozessiert werden miissen. Anstatt jeden einzelnen Arbeits-
schritt fiir jede Satellitenszene immer wieder zu wiederholen, kénnen die einzelnen
Werkzeuge in einem Modell zusammengefasst werden und so Satellitenbilder in einem
einzelnen Arbeitsschritt bearbeitet werden. Das Modell hilft neben der Zeitersparnis
auch, Arbeitsprozesse zu vereinheitlichen, zu optimieren und zu dokumentieren.

Um ein solches Modell zu erstellen, verwendet man den Graph Builder < iiber das

entsprechende Symbol in der Meniileiste oder im Hauptmendii iber Tools > GraphBuilder.

Mit einem Rechtsklick auf die weifle Fldche des GraphBuilder kann man dann die
verschiedenen SNAP-Werkzeuge hinzufiigen, hier am Beispiel Reproject zu sehen. Das
gewdhlte Werkzeug muss anschlieflend noch durch einen erneuten Rechtsklick auf
Reproject > Connect Graph mit der Prozesskette verbunden und die Parameter eingestellt

werden.

[ Graph Builder x B Graph Builder x

File Graphs File Graphs Abb. 51

~ ~
Add > | & input-Output >
e P [l
& Opical > Add >
E__. Radar > o write : I— —'IEI

i Raster > | & Classification > - o )
& Tooks & Data Conversion » e

& vector > | @ DEMTools
&  SmosNetcdfExport i Geometric

Read winite & Mosks

registrationt £
» o Read Write Reproject
—— - S
& BandMerge W Resampl Name:

[2] 528_MS1L24_20210723T102559_N0301_R108_T32UL_207 &  Flip LS [2] 528 _MSIL2A_20210723T102559_N0301_R108_T32LU_20210723T133534 v][=
& Image-Filter

DataFormat: | Any Format v & Subset DataFormat: | Any Format ~

& TemporalPercentile
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Die Werkzeuge, die in den Graph Builder eingeladen werden kénnen, unterscheidenden
sich im Vergleich zum direkten Aufruf haufig minimal in der Parametereingabe:

> Reiter 1/0 Parameters Source Product oder im GraphBuilder Reiter Read: Name des

Satellitenbildes, das eingelesen werden soll.

> Reiter I/0 Parameters Target Product oderim GraphBuilder Reiter Write: Name und

Dateityp fiir die zu speichernde Datei.

In QGIS heifit das Werkzeug fiir die graphische Verarbeitungsmodellierung iibri-
gens grafische Modellierung (engl. Graphical Modeler), in ArcGIS ModelBuilder.

Projektion in ein  anderes Koordinatenbezugssystem
(Reprojection)
Satellitenbilder konnen in unterschiedlichen Koordinatenreferenzsystemen (engl.

Coordinate Reference System CRS) vorliegen, fiir eine Uberfiihrung in eine andere
Projektion kann das Werkzeug Reprojection benutzt werden. Du findest das Werkzeug

> inder Meniileiste unter Raster > Geometric > Reprojection

> im Graph Builder, indem du mit der rechten Cursortaste in das weife Feld klickst
und anschlieend auf Add » Raster > Geometric > Reproject wahlst. AnschlieBend lasst
sich der Prozessierungsschritt mit Hilfe eines erneuten Rechtsklicks auf Reproject »
Connect Graph mit den Schritten Read und write verbinden.

Einfligen der Parameter:

> Reiter I/0 Parameters > Source Product oder im GraphBuilder Reiter Read > Source
Product: Name des Satellitenbildes, das eingelesen bzw. verarbeitet werden soll.

> Reiter I/0 Parameters > Target Product oder im GraphBuilder Reiter Write > Target
Product: Name, Dateityp und Speicherort fiir die zu speichernde Datei.

Reprojection X Abb 52
File Help

I 1/O Parameters l Reprojection Parameters

e

| [1] S2A_MSIL2A_20180207T104211_N0206_R008_T32UME_20180207T 124633 v
—I’arget Product

Name:

S2A_MSIL2A_20180207T104211_N0206_R008_T32UME_20180207T 124633 _reprojected

[7] save as: | BEAM-DIMAP v
Directory:
E:\_SAPIENS\SNAP\MeinProjekt\Processed Products

[fn ][ Gose |
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> Reiter Reprojection Parameters oder im GraphBuilder Reiter Reprojection

> Im Abschnitt Coordinate Refrence System (CRS) kann ein selbst gewdhltes mit
Custom CRS, ein vordefiniertes mit Predefined CRS oder ein Referenzsystem einer
anderen Datei mit Use CRS of gewadhlt werden.

> Im Abschnitt output Settings kannst du das Hakchen bei Preserve resolution

gesetzt lassen, wenn die rdaumliche Auflosung des Eingaberasters beibehalten
werden soll. Wenn nicht, entferne das Hakchen und passe die Parameter unter
Output Parameters an. Ebenso kannst du entscheiden, ob Ankerpunktraster ein-

bezogen werden sollen (Reproject tie-point grids) oder welchen Wert Pixel er-

halten sollen, die im Eingaberaster nicht vorhanden sind oder ungiiltige Werte be-
sitzen (No-data value). Delta-Breiten- und Langenbdnder kannst du hinzufiigen

(Add delta lat/lon bands), wenn du die Genauigkeit der Reprojektion {iberpriifen
mochtest. Auch die Resampling-Methode kannst du auswéhlen (Resampling me-
thod).

> Starte den Prozess iiber die Schaltflache Run. Bei grof¥flachigen Rasterdaten kann das
einige Zeit in Anspruch nehmen.

n Reprojection X A
bb. 53
File Help
1/0 Parameters|| Reprojection Parameters |
Coordinate Reference System (CRS)
(O Custom CRS
Geodetic datum: |World Geodetic System 1984 v
Projection: |Geographk: Lat/Lon (WGS 84) v |
Projection Parameters
@ Predefined CRS |EPSG:25832 - ETRS89 / UTM zone 32N | Select...
OusecRSof | v e
Output Settings
[/ Preserve resolution [ Reproject tie-point grids
Output Parameters... No-data value: NaN |
[] Add delta lat/lon bands Resampling method: Nearest v
Output Information
Scene width: 10981 pixel Center longitude:  8°19'02°E
Scene height: 10981 pixel Center latitude: 53°39'10"N
CRS: ETRS89 / UTM zone 32N | Show WKT |
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Anpassen der raumlichen Auflosung (Resampling / Resample)

Sentinel-2-Daten besitzen 13 Spektralbander mit unterschiedlicher raumlicher Auflésung
(10, 20 und 60 Meter). Wenn Bdnder mit unterschiedlicher Auflosung fiir die
Weiterverarbeitung verwendet werden (z.B. das griine Band 3 mit 10 m und das
kurzwellige Infrarot Band 11 mit 20 m), kénnen die Bander auf eine einheitliche
RastergroRe gebracht werden (engl. resample).

Fiir die Anpassung der Auflésung hadlt SNAP zwei verschiedene Werkzeuge bereit.

Resampling / Resample

Bei fast allen Satellitendaten und -bandern kann das Werkzeug Resampling / Resample

verwendet werden. Das Werkzeug fiir die allgemeine Anpassung der Banderauflosung ist
im Hauptmenii unter Raster » Geometric > Resampling zu finden.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in
das weif3e Feld und anschlieBend auf Add » Raster > Geometric > Resample klickst. Wahle
nach erneutem Rechtsklick > Connect Graph, um die Werkzeuge zu verbinden.

Einfligen der Parameter:

> Reiter I/0 Parameters > Source Product oder im GraphBuilder Reiter Read » Source
Product: Name des Satellitenbildes, das eingelesen werden soll.

> Reiter I/0 Parameters > Target Product oder im GraphBuilder Reiter Write > Target
Product: Name, Dateityp und Speicherort fiir das zu Speichernde.

B Resampling X
File Help

|I)‘CI Parameters I ﬁﬂﬁi’i Parameters

Source Product
MName:
[ [1] S2A_MSIL2A_20180207T104211_N0206_R008_T32UME_20180207T 124633 v

Target Product
MName:
| S2A_MSIL2A_20180207T104211_N0206_R008_T32UME_20180207T 124633 _resampled

[ Save as: | BEAM-DIMAP v]
Directory:
E:\_SAPIENS\SNAP\MeinProjekt\Processed Products

[Z] Open in SNAP

[Ren ][ Gose ]

> Reiter Resampling Parameters oder im GraphBuilder Reiter Resample

> Im Abschnitt Define size of resampled product legst du die anvisierte Auflésung

fest. Du kannst entweder die Auflésung eines bestehenden Referenzbandes wah-
len By reference band from source product (hier Band 1 mit 10 m Auflosung), die
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Auflosung liber die Gesamtbreite (Target width) und -héhe (Target hight) des

Zielproduktes bestimmen (By target width and hight) oder in der dritten Option

By pixel resolution (in m) die Pixelgréf3e individuell manuellin Meter eingeben.

> Im Abschnitt Define resampling algorihtm kannst du angeben, mit welcher Me-
thode der Prozess durchgefiihrt werden soll. Ist eine hohere Auflosung das Ziel,
handelt es sich um Upsampling und man kann die gewiinschte Upsampling-Me-
thode einstellen. Dabei wird ein Pixel aufgespalten und sein Wert je nach Methode
auf neue kleinere Pixel verteilt. Soll sie Auflosung verringert werden, wird das
Downsampling genannt und mehrere Pixelwerte werden — wieder je nach Methode
— zu einem neuen Pixel mit neuem Wert zusammengefasst.

Aktivierst du die Option Advanced Method Definition by Band, kannst du sogar

fiir jedes Band individuelle Methoden auswadhlen und deine Einstellungen fiir spa-
tere Wiederholungen iiber Save Preset speichern bzw. {iber Import Preset aus

einer vorhandenen CSV-Datei importieren.

» Starte den Prozess mit Run.

Resampling X
2 Abb. 55
File Help
1/O Parameters | Resampling Parameters
Define size of resampled product
(®) By reference band from source product: |Bl v|
Resulting target width: 1830
Resulting target height: 1830
(O By target width and height: Target width: [ 10,980 3 |
Target height: | 10,980 & |
Width / height ratio: 1.00000
(O By pixel resolution (in m): | 0 :l
Resulting target width: 1830
Resulting target height: 1830
Define resampling algorithm
Upsampling method: |Naaut v]
Downsampling method: |Frst v
Flag downsampling method: |Frst v]
[[] Advanced Method Definition by Band
IE Resample on pyramid levels (for faster imaging)
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Resample Sentinel-2 Products

Fiir Sentinel-2 gibt es noch ein weiteres Werkzeug Resample Sentinel-2 Products, bei
dem die Winkelbander (diese sind im Ordner view angelegt: Zenit und Azimut) separat

pro Aufnahmedetektorenstreifen berechnet werden. Das Werkzeug ist im Hauptmenii
unter Optical » Geometric > S2 Resampling Processor zu finden.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in
das weif3e Feld und anschlieflend auf Add » Optical » Geometric > S2Resampling klickst.
Wahle nach erneutem Rechtsklick > Connect Graph, um die Werkzeuge zu verbinden.

Bei den Processing Parameters kannst du unter Output resolution die gewiinschte

Auflosung in Metern angeben. Die Prozessierung ist allerdings sehr rechenaufwendig und

es ist zu empfehlen, das Werkzeug nur dann zu benutzen, wenn die Winkelinformationen
fiir die weitere Prozessierung benétigt werden.

H S2 Resampling X

Abb. 56

File Help

1O Parameters Processing Parameters

Upsampling method: _ﬁnex v
Downsampling method: Mean v
Flag downsampling method: First v]

[#] Resample on pyramid levels (for faster imaging)

Raumliches Zuschneiden und Auswiahlen der Bander (Subset)

Bander kdnnen zu einem ,,Paket*“ kombiniert werden (engl. band composite, stack oder
subsel) und auf einen rdaumlichen Ausschnitt zugeschnitten werden (engl. subsei).

Wenn nicht alle Bander und/oder ein bestimmtes Gebiet aus der Satellitenszene benétigt
werden, ist es sinnvoll die Datenmenge zu reduzieren. Sowohl die Auswahl von Bdandern
als auch der Zuschnitt auf einen Ausschnitt erfolgt mit dem Werkzeug Subset, das unter

Raster > Subset... im Meni zu finden ist.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in
das weif3e Feld und anschlieflend auf Add » Raster » Subset wahlst. Wahle nach erneutem
Rechtsklick > Connect Graph, um die Werkzeuge zu verbinden.

Einfiigen der Parameter:

> Im GraphBuilder Reiter Read & Write: Auswahl des Satellitenbildes, das eingelesen
werden soll sowie Speicherpfad und -name. Wenn du das Werkzeug stattdessen iiber
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das Menii gewahlt hast, wird das Subset an das ausgewdhlte Satellitenbild als neuer
Ordner angehdngt.

> Reiter spatial Subset oder im GraphBuilder Reiter Subset: Hier kannst du {iber ein
Referenzband (hier Band 2 mit 10 m Auflésung) bzw. im GraphBuilder {iber Source
Bands die Auflésung angeben sowie den raumlichen Ausschnitt festlegen, z.B. visuell
durch das Aufziehen und Verschieben eines Auswahlquadrates mit gehaltener
Maustaste. Du kannst die Auswahl aber auch durch exakte Pixel- oder
Koordinatenwerte iiber die Reiter Pixel Coordinates bzw. Geo Coordinates
definieren. Das Auswahlquadrat in der Bildvorschau passt sich entsprechend an. Im
GraphBuilder klickst du hierfiir auf Geograpic Coordinates, gibst die Koordinaten als
WTK Code unter der Karte ein und wahlst update (vgl. S.44, Vektordaten einladen,
erstellen und WTK-Code).

Beispiel fiir WTK Code eines Polygons:
POLYGON ((363669.2570145908 5844972.529051196, 365157.0221876882

5844972.529051196, 365157.0221876882 5843586.025382026, 363669.2570145908
5843586.025382026, 363669.2570145908 5844972.529051196))

> Reiter Band Subset: Hier wahlst du per Hakchen aus, welche Bander das Subset ent-
halten soll.

> Mit oK oder im GraphBuilder mit Run startest du den Prozess.

E Specify Product Subset X A
bb. 57
Spatial Subset || Band Subset Tie-Point Grid Subset Metadata Subset

Al Reference Band:|B2 v

I Pixel Coordinates IGeo Coordinates I
- o Scene start X: | 4608 3
M T £l Scene start Y: | 5616 -
O R Scene end X: | 77033
S ; 0 5 Scene end Y: | 82075

i ag 1
e o Scene step X: 15
Scene step Y: 15
Subset scene width: 3096.0
Subset scene height: 2592.0
Source scene width: 10980
Source scene height: 10980
[] Fix full width
Use Preview |
V) [] Fix full height
Estimated, raw storage size: 121.6M

[ o |
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Das Produkt erscheint nun im Product Explorer als subset_x. Durch Rechtsklick auf den
Namen kann es als Datei abgespeichert werden. im GraphBuilder wird es im aktuellen

Beispiel direkt als Datei unter dem gewdhlten Pfad abgespeichert.

Zusammensetzen einzelner Satellitenszenen (Mosaicking)

Erstreckt sich das Untersuchungsgebiet iiber mehrere Satellitenszenen, kénnen diese
wie ein Mosaik zusammengesetzt und in einer Datei zusammengefasst werden. In SNAP
kann mit dem Werkzeug Mosaicking bzw. Multi-size Mosaic zudem bei der Mosaikierung

die gewiinschte Auflosung, eine Auswahl der bestehenden Bander und bei Mosaicking
sogar neue Bander mit Expression berechnet werden (vgl. S. 44, Bander Berechnunngen
— Werkzeug Band Maths). Die Werkzeuge sind unter Raster > Geometric > Mosaicking im

Hauptmenii zu finden. Das Werkzeug Multi-size Mosaic wird gewdhlt, wenn das

eingeladene Satellitenbild unterschiedliche Auflosungen hat, wie beispielsweise
Sentinel-2-Aufnahmen.

Im GraphBuilder wird nur das Werkzeug Multi-size Mosaic angeboten. Du kannst es
aufrufen, indem du mit der rechten Maustaste in das weifle Feld klickst und

anschlieflend Add > Raster » Geometric »Multi-size Mosaic auswadhlst.

Einfligen der Parameter:

> Im Reiter 1/0 Parameters oder im GraphBuilder Reiter Read & Write: Auswahl der Sa-
tellitenbilder, die eingelesen werden sollen und Speichername.

> Reiter Map Projection Definition das gewiinschte Referenzsystem iiber Predefined
CRS » Select.. wahlen. Zudem gibt es die Option, im Abschnitt Orthorectification das
Mosaik zu orthorektifizieren und im Abschnitt Mosaic Bounds gleich auf das ge-
wiinschte Untersuchungsgebiet zuzuschneiden.
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- Multi-size Mosaic s
File Help Abb. 58
B ooy W
Coordinate Reference System (CRS)
(O Custom CRS
Geodetic datum: |World Geodetic System 1984 v]
Projecton: | Geographic Lat/Lon (WGS 84) v]
| Projection Parameters... |
l@ndeﬁndmslmss:zsaaz-msawmumm I Select... I
S———
Orthorectification
[] Orthorectify input products
Elevation model: SRTM 3Sec ~]
Mosaic Bounds
West: | 7.4686867 ° East: | 5.14942563|° Pixel size X: | 1000.0|m
North: | 5414301139 ¢ South: | 53.15177793 © Pixel size ¥: | 1000.0|m
Perform mosaic at native resolution
Overlapping methods
|MosAIC_TYPE_OVERLAY v
[[] Display source products

Bei der Bestimmung der Variablen unterscheiden sich die Werkzeuge:

> Reiter variables bei Mulit-size Mosaic: Mit dem Papiere-Symbol B kannst du hier
die gewiinschten Bander per Hakchen auswahlen.

B Mutti-size Mosaic X
File Help - Band Chooser b M
1/O Parameters Map Projection Definition Variables D E1: Refiectance Mbm B1¢4430mn) A | B
E]Bn Reflectance in band B11 (1610.0 nm)
— Ostz Reflectance in band B12 (2150.0 nm) @
5 4 ¥ e2 Reflectance in band B2 (450.0 nm)
E B3 Reflectance in band B3 (560.0 nm)
Mes Reflectance in band B4 (665.0 nm)
es Reflectance in band B5 (705.0 nm)
[Jee Reflectance in band BE (740.0 nm) —
er Reflectance in band B7 (783.0 nm)
Mes Reflectance in band B8 (842.0 nm)
[Jesa Reflectance in band B8A (865.0 nm)
Oee Reflectance in band B9 ($45.0 nm)
[] quality_sot Aerozol Optical Thickness v
[Jselectal [[] Select none
ST -

> Reiter variables & Conditions bei Mosaicking: Mit dem Papiere-Symbol B, kannst du
das gewiinschte Band mit einem Hakchen auswadhlen. Neue Bander kannst du mit dem
Plus-Symbol ¥ hinzufiigen. Mit einem Doppelklick auf das Feld unter Expression
bzw. auf das 3-Punkte-Sybol ==! kannst du eine Formel fiir die Berechnung eingeben.
Im Abschnitt Conditions kannst du {iber das Plus-Symbol ®# zusatzliche Regeln hin-
zufiigen und wieder iiber boppelklick auf das Feld unter Expression bzw. auf das 3-
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Punkte-Sybol =1 den Ausdrucksgenerator 6ffnen, um zu bestimmen, welche Pixel in
das Mosaik tibernommen werden sollen.

> Mit oK oder im GraphBuilder mit Run startest du den Prozess.

B Mosaicking X

B x|
File Help Abb. 60
Data sources: Expression:
1/O Parameters  Map Projection Definitiorl| Variables & Conditions | | [ ~ e ana @ ~ I
Variables B2 e
[ ] ERCER. = v

not @

[ Show bands
Name @
] Show masks
v
3 D 5 E‘Wﬂtm Constants... v

B4 B4 Show single flags e > E ili ° . ’

¥

T
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Wie kann ich mein Untersuchungsgebiete festlegen?

Vektordaten einladen, erstellen und WTK-Code

Fiir die Bearbeitung von Satellitendaten werden hadufig auch Vektordaten benétigt,
beispielsweise fiir die Grenzen eines Untersuchungsgebietes, auf das die Satellitendaten
zugeschnitten werden sollen oder Daten aus dem Geldnde fiir die Klassifikation.

Im Unterschied zu den meisten anderen Programmen, mit denen Satellitendaten ver-
arbeitet werden konnen, werden die Vektordaten als Unterordner Vector Data einer

Satellitenszene aufgefiihrt.

Das bedeutet, dass immer eine Satellitenszene ausgewahlt sein muss, um Vek-
tordaten einzuladen oder zu erstellen.

Sollte der Ordner noch nicht existieren, fiige ihn durch Vector > New Vector Data
Container hinzu. Daraufhin erscheint er in deinem Product Explorer.

Das Einladen von bestehenden Vektordaten wie beispielsweise einer ESRI Shape-Datei
(.shp) erfolgt im Menii liber Vector » Import > ESRI Shapefile. Auch comma-seperated

values (.csv), also kommagetrennte Textdateien konnen verwendet werden.

Fiir die Erstellung von neuen Vektordaten kannst du dir eins der
Digitalisierungswerkzeuge aussuchen. Hier im Beispiel wurde ein Rechteck aufgezogen
mit dem Werkzeug Rectangel drawing tool E!. Sofern kein neuer Name vergeben wurde,

werden die Vektordaten als geometry im Ordner Vector data abgelegt.

Zum Speichern der Daten wahlst du im Menii File » Save Product. Mit einem Rechtsklick
auf geometry und Geometry as Shape file kannst du die Daten auch als ESRI Shapefile

speichern.

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help
SR Dbl PR PnUORLLT GBBLSE NS » 0a s B Abb.61

Product Explorer X | Pixelinfo | — | [ B (1] Sentinel 2 MSI Natural ColorsRGB X
=& [1] S2A_MSIL2A_20180207T104211_N0206_R008_T32UME_20180207T1] || 1

Open Placemark Window
Geometry as Shape file

Ctrl+X
Copy Ctrl+C

Ctrl+V

Navigatio... X | Colour

Bei einigen Werkzeugen, wie dem Zuschneiden einer Satellitenszene auf ein kleineres
Untersuchungsgebiet, werden die Informationen als WTK (Well-known-Text-Reprdsen-
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tation) bendtigt. Dieser WTK Code kann durch einen bDoppelklick auf geometry angezeigt
und per Rechtsklick und Copy to clipboard tempordr kopiert werden. Leider werden

immer alle Geometrien abgespeichert; bei mehreren Polygonen wie im Beispiel kann die
gewiinschte Zeile durch vorheriges Kopieren in einen Texteditor ausgewahlt werden.

B snap

File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help Abb. 62
aB oNnBALACe T re o A \NVEYOR = \ MEBHD

Product Explorer X | Pixelinfo | — |/ [1) Sentinel 2 MS1 Natural ColorsRGB X | [1] geometry X |
©-& [1] S2A_MSIL2A_20190726T102031_N0213_R065_T33UUU_20190726T 125507 A
©-03 Metadata OLYGON ((316608.92159970215 5369888, 198595988, 365053.0826931671 5869888.

- (@ Index Codings 329161.970642} Copy to cipboard, 1/0.41624149436 5841835.3753837...
= U.2 5846668.00459255...

=@ Vector Data 354739.5447474.
-~ pns
5" N ground_control_points
th geometry
- (@2 Tie-Point Grids
@3 Bands
- (3 Masks

Masken

Masken werden verwendet, um bestimmte Gebiete der Satellitenszene zu markieren.

Entweder um ein Untersuchungsgebiet festzulegen und fiir die weitere Bearbeitung
auszuwdhlen oder beispielsweise bei Wolken, um diese Pixel bei den weiteren
Prozessschritten wegzulassen.

Ebenso wie die Vektoren werden Masken als Unterordner Masks einer Satellitenszene

aufgefiihrt. Das bedeutet, dass immer eine Satellitenszene ausgewahlt sein muss.

=

Bearbeitet werden Masken im Mask Manager = , zu finden im Meni unter View > Tool

Windows > Mask Manager. Bei Sentinel-2 gibt es hier schon einige bestehende Masken.

Neue Masken kannst du auf verschiedenen Wegen erstellen, durch:

1. Kalkulationen mit den Satellitenbdndern iiber das Funktions-Symbol f® (engl.
logical band maths expression).

2. Definition eines Wertebereichs iiber das [x]-Symbol X (engl. value range).

3. Erstellte Linien oder Flachen als Vektoren iiber das Container-Symbol 2 (engl.
geometry container) und anschlieRendes Vektor-Zeichnen mit ™ v B 9 @ &

4. Operationen mit bestehenden Masken, wie z.B. Verschneiden (engl. union) .
5. Importieren von bestehenden Masken iiber das Import-Symbol & .

Name, Farbe und Transparenz (engl. transparency) kannst du anpassen.

: Mask Manager X &5 ‘

= Abb. 63
@D | Name Type Colour Tra... Description g_
[] |detector... (Geometry ([l 0.5 Detector footprint mask - B2 Py =
|:] detector... |Geometry 0.5|Detector footprint mask - B2 g
[] |detector... (Geometry |||  ©.5Ppetector footprint mask - B2 & E
=
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Wie berechne ich Indizes?

Kombinationen und Berechnungen mit einzelnen Spektralkandlen, wie dem Vegetations-
index NDVI (normalisierter differenzierter Vegetationsindex) *°, sind bei einer Vielzahl
von Anwendungen niitzlich, um die gewiinschten Informationen aus einem Satellitenbild
zu extrahieren. Hierbei stellt die SNAP Toolbox vordefinierte Indizes bereit, die fiir Land

mit Thematic Land Processing und Wasser mit Thematic Water Processing angewendet
werden kdnnen. Zudem kdnnen eigene Indizes mit dem Werkzeug Band Maths berechnet

werden.

Indizes fiir Wasserflachen

Radiometrische Meeresindizes (S2 MCI Processor)

Aktuell gibt es im Hauptmenii unter Optical > Thematic Water Processing > S2 MCI
Processor fiir Wasserflachen einen Index, die Berechnung der Intensitdt der Algenbliiten
im Wasser durch den Maximum Chlorophyll Index MCI. Der MC/-Index von Gower et al*

funktioniert am besten fiir Sentinel-2-Daten.

Radiometrische Wasserindizes (Water Radiometric Indices)

Daneben werden weitere Indizes unter Optical > Thematic Land Processing > Water
Radiometric Indices angeboten.Im GraphBuilder wird das Werkzeug hinzugefiigt, indem
mit der rechten Maustaste in das weif3e Feld und anschlieflend auf Add » Raster » Optical

> Thematic Land Processing ausgewdhlt wird.

Die Processing Parameters konnen hierbei bei den Standardwerten belassen werden,

sofern nicht Bdnder mit unterschiedlicher Auflosung und Gewichtung verwendet werden.
Folgende Indizes werden zum Thema Wasser bereitgestellt:

»  Der Normalisierte Differenzierte Wasser-Index NDWI nach Gao **: Normalized Diffe-

rence Water Index NDWI: (Blatt-) Wassergehalt der oberen Vegetation

> Der Modifizierte Normalisierte Differenzierte Wasser-Index NDWI2 nach McFeeters
Normalized Difference Water Index NDwI2: Wasserflachen

> Der Modifizierte Normalisierte Differenzierte Wasser-Index MNDWI nach Xu ** Modi-

fied Normalized Difference Water Index MNDWI: verbesserter NDWI2 (reduziert feh-
lerhafte Klassifikation von bebauten Flachen, Boden und Vegetation)

> Der Normalisierte Differenzierte Teich-Index NDPI nach Lacaux & al. *> Normalized

Difference Pond Index NDPI: kleine Wasserflachen (bis 0.01ha) und Vegetation in

kleinen Wasserflachen

> Der Normalisierte Differenzierte Wassertriibung-index NDTI nach Lacaux & al. *> Nor-

malized Difference Turbidity Index NDTI: Wassertriibung
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Indizes fiir Landflachen

Unter Optical > Thematic Land Processing wird eine Vielzahl von Indizes fiir die

Verwendung an Land von SNAP bereitgestellt. Im GraphBuilder wird das Werkzeug
hinzugefiigt, indem du mit der rechten Maustaste in das weif3e Feld und anschlieBend auf
Add > Raster > Optical > Thematic Land Processing wdhlst.

Die Processing Parameters konnen hierbei bei den Standardwerten belassen werden,

sofern nicht Bander mit unterschiedlicher Auflosung und Gewichtung verwendet werden.
Sie sind in Indizes fiir Boden, Vegetation, biophysikalische Parameter und Verdnderungs-
analyse von Waldflachen unterteilt.

Bodenindizes (Soil Radiometric Indices)
Radiometrische Bodenindizes: (Soil Radiometric Indices)

»  Der Helligkeitsindex Bl nach Escadafal*® Brightness Index BI: Durchschnittliche Hel-
ligkeit des Satellitenbildes

> Der Zweite Helligkeitsindex Bl2 nach Escadafal’® The second Brightness Index BI2:

Durchschnittliche Helligkeit des Satellitenbildes, Ergebnis dhnelt einer panchromati-
schen Aufnahme

> Der Rétungsindex Rl nach Pouget et al. "’ Redness Index RI: Bodenfarbenvariation

> Der Farbenindex Cl nach Pouget et al. Colour Index CI: Bodenarten

Vegetationsindizes (Vegetation Radiometric Indices & Soil Radiometric Indices)
Radiometrische Bodenindizes: Soil Radiometric Indices

> Der an Boden Angepasste Vegetationsindex SAVI nach Huete et al. *® Soil Adjusted

Vegetation Index SAVI: Vegetationsindex der Bodeneigenschaften beriicksichtigt

> Der Transformierte, an Boden Angepasste Vegetationsindex TSAVI nach Baret et al. *°
und Baret und Guyot *° Transformed Soil Adjusted Vegetation Index TSAVI: Vege-

tationsindex der Bodeneigenschaften und Hangneigung beriicksichtigt

> Der Modifizierte, an Boden Angepasste Vegetationsindex MSAVI nach Qi ** Modified

Soil Adjusted Vegetation Index MSAVI: Vegetationsindex der unter Beriicksichti-
gung von NDVI und WDVI

> Der Zweite Modifizierte, an Boden angepasste Vegetationsindex MSAVI2 nach Qi *
The second Modified Soil Adjusted Vegetation Index MSAVI2: Iterationsprozess mit

MSAVI

Radiometrische Vegetatonsindizes Vegetation Radiometric Indices

> Der Normalisierte Differenzierte Vegetationsindex NDVI nach Rouse et al. >**>> Norma-
lized Difference Vegetation Index NDVI: photosyntetische Aktivitat / Vitalitat
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Der Differenzierte Vegetationsindex DVI nach Tucker?* bifference Vegetation Index

DVI: Vegetationsmenge

Der Ratio Vegetationsindex RVI nach Birth und McVey * Ratio Vegetation Index RVI:

Vegetationsmenge (reduziert Effekte der Atmosphare und Topologie)

Der Perpendikularer Vegetationsindex PVI nach Richardson und Wiegand *° Perpen-

dicular Vegetation Index PVI: dhnlich zu DVI fiir unterschiedliche Hangneigung

Der Prozentualer Infrarot Vegetationsindex IPVI nach Crippen *” Infrared Percentage

Vegetation Index IPVI: dhnlich zu NDVI & RVI mit einem Wertebereich o-1

Der Gewichtete Vegetationsindex WDVI nach Clevers *° Weighted Difference Vegeta-

tion Index WDVI: vereinfachter PVI

Der Transformierte Normalisierte Differenzierte Vegetationsindex TNDVI nach Tucker
“’Transformed Normalized Difference Vegetation Index TNDVI: griine Biomasse pro

Pixel

Der Griine Normalisierte Differenzierte Vegetationsindex GNDVI nach Gitelson et al, %
Green Normalized Difference Vegetation Index GNDVI: dhnlich zu NDVI, sensitiver

Der Globale Umweltmonitoring Index GEMI nach Pinty und Verstraete ° Global En-

vironmental Monitoring Index GEMI: Atmosphdrenkorrektur

Der Atmosphdrenresistente Vegetationsindex ARVI nach Kaufman und Tanre > Atmo-

spherically Resistant Vegetation Index ARVI: atmosphdrische Durchldssigkeit

Der Normalisierte Differenzierte Vegetationsindex NDI45 nach Delegido et al. > Noxr-

malized Difference Index NDI45: dhnlich zu NDVI, weniger Sattigung bei hoheren
Werten

Der Meris Terrestrische Chlorophyll-Index MTCI nach Dash und Curran 3 Meris Ter-

restrial Chlorophyll Index MTCI: Chlorophyllgehalt fiir MERIS Daten

Der Modifizierte Chlorophyll-Absorptions-Ratio-Index MCARI nach Daughtry et al. 3*
Modified Chlorophyll Absorption Ratio Index MCARI: Chlorophyllgehalt unter Be-

riicksichtigung von Bodenreflektanzen

Der Red-Edge Wendepunktindex REIP nach Baret et al, 3> Red-Edge Inflection Point
index REIP: Biomasse und Stickstoffaufnahme in heterogener Vegetation

Der Sentinel-2 Red-Edge Positionsindex S2REP nach Baret et al. 3> Sentinel-2 Red-

Edge Position index S2REP: Schatzt den Knickpunkt (engl. Inflexion point) der Vege-
tation im Red-Edge Bereich mit Band 5 & 6 von Sentinel-2 Daten

Der /nvertierte Red-Edge Chlorophyll-Index IRECI nach Baret et al. 3> und Clevers et al.
2 Inverted Red-Edge Chlorophyll Index IRECI: Chlorophyllgehalt der Baumkrone
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> Der Pigmentspezifische Einfache Ratio-(Chlorophyll-) Index PSSRa nach Blackburn 3°
Pigment Specific Simple Ratio (chlorophyll) index PSSRa: Pigmente der Baum-

krone

Biophysikalische Parameter (Biophysical Variables Processor)

Weitere Vegetationsmerkmale konnen aus Sentinel-2B-Reflexionsdaten mit dem
Werkzeug Biophysical Variables Processor fiir die obere Vegetationsdecke

/Blattschicht generiert werden, diese sind:

> Der Blattflachenindex BFl nach Rouse et al. > Leaf Area Index LAI: Effektive Blattfla-

che pro Bodenoberflache (< 1: mehr Boden, » 1: mehr Vegetation)

>  Die fraktion der fotosynthetisch Aktiven Strahlung FAPAR nach Prince ¥ Fraction of
Absorbed Photosynthetically Active Radiation FAPAR: Anteil der von der Vegetation

absorbierten Strahlung um Wellenlangenbereich von 0,4 — 0,7 pm der fiir die Photo-
synthese verfiigbar wire.

> Die Fraktion der Vegetationsbedeckung FCOVER nach Weiss et al. > Fraction of ve-

getation cover FVC: Maf fiir die Vegetationsbedeckung unabhdngig von der Sonnen-
lichteinfallsrichtung

> Der Chlorophyllgehalt nach Houlés et al, 3 Chlorophyll content in the leaf Cab:

guter Indikator fiir Stickstoffmangel der Vegetation

>  Wassergehalt der Blattoberflache nach Hunt und Rock “*° Canopy Water Content CWC

Waldverdnderung (Forest Cover Change Processor)

Der Forest Cover Change Processor unter Optical > Thematic Land Processing (im

GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in das
wei3e Feld und anschlieBend Add » Raster > Optical > Thematic Land Processing wahlst)

ist eine interaktive Werkzeugreihe das aus zwei Satellitenszenen zu unterschiedlichen
Zeitpunkten die Veranderung der Waldbedeckung berechnen kann. Die Berechnung ist
sehr rechenenintensiv. Die Hauptprozesse sind wie folgt:

> multitemporale Segmentierung
> Verdnderungsanalyse

> Erstellung von Trainingsdaten aus bestehenden Landbedeckungsdaten (z.B. CCl
Landbedeckungskarte der ESA )

> Berechnung der Ratio von Veranderungsbdndern einzelner Wellenlangenbereiche
> Bindre Wald / kein Wald Klassifikation der Segmente

> Klassifikation der Verdnderungen im Vergleich zu der Waldmaske aus beiden Zeit-
punkten
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Einfligen der Parameter:

> ImI/0 Paramters Reiter unter Recent Data Product die Satellitenszene aus dem ak-
tuelleren Zeitpunkt 1 wahlen und unter Previouse Data Product die dltere Szene zum
weiter zuriickliegenden Zeitpunkt 2 wahlen. Unter Target Data Product den Speicher-
namen eingeben.

> ReﬂerProcessing Prameters

> Forest cover percentage: Anteil Waldflache aus CCl Land Cover Referenzda-

ten pro Segment, die als Eingangsdaten fiir die Klassifikation verwendet wer-
den.

> Merging cost criterion: Verbindungskosten zweier benachbarten Segmente

/ Homogenitat. Bestimmt ob zwei Segmente getrennt bleiben oder verbunden
werden.

> Region merging criterion: Kriterien wie benachbarte Segmente miteinander
verbunden werden.

> Total iterations: Anzahl der Durchldufe.

> Thresdhold: Schwellenwert, um Untersegmentierung zu vermeiden (je hoher

desto geringer Wahrscheinlichkeit der Untersegmentierung).
> Spectral weight

> Shape weight

> Name: Wahl der zur Verfiigung stehenden Landnutzungskarten fiir die Trai-

ningsdaten, die bereits im Werkzeug fiir die Klassifikation der Waldflachen
vorhanden sind, standardmaflig ist dies die CCl Land Cover map.

> Map Indicies: Klassen, die aus der Landnutzungskarte fiir die Waldmaske ver-

wendet werden sollen, Werte miissen integer und durch Komma getrennt sein.
(Ftir cal Land Cover Map beispielsweise
40,50,60,61,62,70,71,72,80,81,82,90,100).

> Degree freedom: je kleiner der Wert, desto mehr Segmente werden wahrend
des Trimmungsprozesses geloscht.

> Mit ok oder im GraphBuilder mit Run den Prozess starten
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Berechnungen mit Bandern konnen mit dem Werkzeug Band Maths ausgefiihrt werden.

Dieses findet man entweder unter Raster im Hauptmenii oder durch einen Rechtsklick

auf die entsprechende Satellitenszene.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem mit der rechten Maustaste in das
weifle Feld und anschlieBend auf Add > Raster > BandMaths gewdhlt wird. Wahle nach

erneutem Rechtsklick > Connect Graph, um die Werkzeuge zu verbinden.

Einfligen der Parameter:

> Load und Save und im GraphBuilder Reiter Read & Write: Auswahl des Satellitenbildes,

das eingelesen werden soll und Speichername. Das neu entstandene Band kann als
Datei, als Ebene des Satellitenbildes oder als virtuelles Band gespeichert werden. Bei
der direkten Wahl des Werkzeuges gibt es nur die zwei letzten Optionen, das Spei-
chern als Datei ist dann aber separat als neuer Schritt durch Rechtsklick auf das Band

moglich.

> Edit Expression.. wahlen und die Formel fiir die Kalkulation eingeben, z.B. fiir den

NDVI aus Sentinel-2 Daten: (B8 — B4) / (B8 + B4). Formeln kdnne auch als Textdatei

eingeladen und gespeichert werden.

> Mit ok oder im GraphBuilder mit Run den Prozess starten

B 8and Maths X
Target product:
|[1] 524_MSIL2A_20190726T102031_N0213_R065_T33UUL_20190726T125507

|
\
Description: J
\
\

[ Virtual only, don't
[ Replace Nai and infinity resuits by HIH‘

[ ] Generate associated uncertainty band
Band maths expression:
(B8 -B4) / (B8 +B4)

[ Band Maths Expression Editor
Data sources:

Bl

B2

B3

B4
BS
BE

B7

B8
BEA

BS

[ Show bands

[ Show masks

[ Show tie-paint grids:
Show single flags

<

Abb. 64
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Wie kann ich weitere Bildinformationen extrahieren?

Strukturinformationen (Texture Analysis Grey Level Co-
occurrence Matrix)

Fiir die Satellitenbildklassifikation kann es neben Indizes auch hilfreich sein,
Strukturinformationen der Oberflaichenbeschaffenheit mit einflieBen zu lassen.** Durch
Texturparameter, also typische Muster, wird die rdumliche Verteilung in der
Nachbarschaft eines Pixels beschrieben. Hierzu zdhlen u.a. Homogenitat, Kontrast und
Abweichung mit Mittelwert. Die Berechnung der Grauwertevariationen erfolgt pro
ausgewdhltem Band mit dem Werkzeug Grey Level Co-occurrence Matrix, das unter

Raster > Image Analysis > Texture Analysis im Hauptmenii zu finden ist.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in
das weif3e Feld und anschlieBend auf Add » Raster > Image Analysis > Texture Analysis >
GLCM wahlst. Wahlen nach erneutem Rechtsklick > Connect Graph, um die Werkzeuge zu
verbinden.

Einfligen der Parameter:

> Load und Save und im GraphBuilder Reiter Read & Write: Auswahl des Satellitenbildes,

das eingelesen werden soll und Speichername. Das neu entstandene Band kann als
Datei, als Ebene des Satellitenbildes oder als virtuelles Band gespeichert werden. Bei
der direkten Wahl des Werkzeuges gibt es nur die zwei letzten Optionen, das Spei-
chern als Datei ist dann aber separat als neuer Schritt durch Rechtsklick auf das Band

moglich.
> Source Bands: Auswahl der Bander

> Window Size: Auswahl der Fenstergrofie, liber die die Texturparameter berechnet wer-

den sollen

> Angle: Auswahl der Winkel
> Quantizer: Zdhlen equal distance oder Wahrscheinlichkeit probabilistic

> Quantization Levels: bit-Tiefe der Ergebnisse
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Datenreduktion, Bildverbesserung (Principal Component Analysis)

Die Hauptkomponenten-/Hauptachsentransformation (engl. principal component ana-
lysis (PCA)) dient der Datenreduktion ohne Informationsverlust.** Einzelne Bander von
Satellitenbildern sind hoch miteinander korreliert und durch Transformation werden
neue Bander anhand der Eigenvektoren und Kovarianzmatrix der einzelnen Bander
erstellt. Das erste Band erhdlt iiblicherweise 95% der Informationen aller spektralen
Badnder. In SNAP ist das Werkzeug {iber das Hauptmenii Raster > Image Analysis >

Principal Component Analysis zu finden.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in
das weif3e Feld und anschlieflend auf Add > Raster > Image Analysis > PCA wahlst. Wahle

nach erneutem Rechtsklick » Connect Graph, um die Werkzeuge zu verbinden.

Einfligen der Parameter:

> Load und Save und im GraphBuilder Reiter Read & Write: Auswahl des Satellitenbildes,

das eingelesen werden soll und Speichername. Das neu entstandene Band kann als
Datei, als Ebene des Satellitenbildes oder als virtuelles Band gespeichert werden. Bei
der direkten Wahl des Werkzeuges gibt es nur die zwei letzten Optionen, das Spei-
chern als Datei ist dann aber separat als neuer Schritt durch einen Rechtsklick auf

das Band moglich.

> Source Bands: Auswahl der Bander
> Maximum component count: maximal Anzahl der Komponenten
> ROI mask name: Angabe einer Maske

>  Mit 0k im GraphBuilder mit Run den Prozess starten
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Wie kann ich Satellitenbilder klassifizieren?

Fiir die Klassifikation von Satellitenbildern stehen in SNAP eine Reihe von Algorithmen
zur Verfiigung.

Klassifikation ohne Trainingsdaten (Unsupervised Classification)

Uniiberwachte Klassifikationsalgorithmen verwenden keine Trainingsdaten, sie klassi-
fizieren also ohne eine Zuordnung zu bestimmten Objektnamen. In SNAP findest du das
Werkzeug iiber das Menii Raster » Classification > Unsupervised Classification.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in
das weifle Feld und anschlieBend auf Add > Raster > Classification > Unsupervised

Classification wadhlst. Wahle nach erneutem Rechtsklick > Connect Graph, um die
Werkzeuge zu verbinden.

Folgende Algorithmen stehen zur Verfiigung:

> Mitdem Werkzeug K-Means Cluster Analysis werden Pixel eine Anzahl k von Klassen

anhand der Euklidischen Distanz nach dem Zufallsprinzip der Zentren zugeordnet. Je-
des Ergebnis sieht anders aus. Diese Methode ist rechnerintensiv und fiir kleine Sze-
nen geeignet.

> Das Werkzeug EM Cluster Analysis ist ein vereinfachter K-Means Algorithmus, bei

dem die Klassen von vordefinierten Wahrscheinlichkeiten gebildet werden. Diese Me-
thode ist schnell und einfach.

Die Werkzeuge haben folgende Parameter:

> Load und Save und im GraphBuilder Reiter Read & Write: Auswahl des Satellitenbildes,

das eingelesen werden soll und Speichername. Das neu entstandene Band kann als
Datei, als Ebene des Satellitenbildes oder als virtuelles Band gespeichert werden. Bei
der direkten Wahl des Werkzeuges gibt es nur die zwei letzten Optionen, das Spei-
chern als Datei ist dann aber separat als neuer Schritt durch einen Rechtsklick auf

das Band moglich.

> Number of clusters: Anzahlder Klassen

> Number of iterations: Anzahl der Klassifikationsdurchldufe, je mehr desto genauer,

aber auch rechenintensiver

> Random seed: Der Algorithmus startet mit einer Pseudozufallszahl, Voreinstellung ist
31415.

> Source band names: Auswahl der Bander
> ROI mask name: Angabe einer Maske

> Mit Run den Prozess starten
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Klassifikation mit Trainingsdaten (Supervised Classification)

Uberwachte Klassifikationen haben die Gemeinsamkeit, das zuvor definierte
Trainingsdaten (meist Vektoren) in den Algorithmus mit eingehen und maBgeblich von
diesen bestimmt werden.

Trainingsdaten konnen

> ein Raster sein, dieses muss sich im Ordner Bands der Satellitenszene befinden.

> Vektor-Polygone (Flachen) sein, die im Ordner Vector Data gespeichert oder erstellt
wurden.

> ein gespeicherter Klassifikator sein.

In SNAP ist das Werkzeug {iber das Hauptmenii Raster » Classification > Supervised

Classification zu erreichen.

Im GraphBuilder wird das Werkzeug hinzugefiigt, indem du mit der rechten Maustaste in
das weife Feld und anschlieBend auf Add > Raster > Classification > Supervised

Classification gehst. Wahlen nach erneutem Rechtsklick > Connect Graph, um die
Werkzeuge zu verbinden.

Folgende Algorithmen stehen zur Verfiigung:

1. Random Forest Classifier **: Das Werkzeug Random Forest Classifier RF ist eine

Regressionsbaumtechnik. Mehrere unkontrollierte Entscheidungsbaume kdnnen in
einem Wald entstehen, Klassen werden durch Stimmenanzahl gebildet. Die Methode
wird sehr hdufig angewendet, ist sehr schnell und fiir groe Datenmengen gut
geeignet.

2. K-Ndchster-Nachbarn-Klassifikator*®:

a. Das Werkzeug KNN Classifier ist ein nonparametrischer Klassifikator, der ein

Pixel zur k-ndchsten Trainingsklasse nach dem Mehrheitsprinzip zuweist. Bei
geringer Anzahl an Trainingsgebiete ist diese Methode sehr ungenau.

b. Das Werkzeug KD Tree KNN Classifier ist ein schnellerer und verbesserter

KNN-Klassifikator, der zu dem gleichen Ergebnis fiihrt.

3. Maximum Likelihood Klassifikator“®: Das Werkzeug Maximum Likelihood Classifier

ist ein parametrisches Schdtzverfahren, mit dem ein Pixel mit der maximalen
Wahrscheinlichkeitsfunktion einer Trainingsklasse zugeteilt wird. Diese Methode ist
einer der bekanntesten Klassifikationsmethoden, hat jedoch an Popularitat durch
vermehrte Wahl der Random-Forest Klassifikation verloren.

4. Minimal Distanz Klassifikator “’: Das Werkzeug Minimum Distance Classifier weist

Pixeln die arithmetisch nachste Klasse anhand der Spektralwerte zu. Diese Methode
ist einfach und weniger rechenintensiv.
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5. Supported Vector Machine Klassifikator (SVM): Das Werkzeug Supported Vector
Machine Classification SvMwird im Hilfsdokument aufgelistet, ist aber aktuell nicht
in SNAP implementiert (Stand Oktober 2022).

Die oben genannten Werkzeuge haben folgende Parameter:

> Productset-Reader und Write und im GraphBuilder Reiter Read & Write: Auswahl des
Satellitenbildes, das eingelesen werden soll und Speichername.

> Train and apply classifier: Name eingeben
> Load and apply classifier: bestehender Klassifikator kann geladen werden
> Number of training samples: Anzahl der Trainingsdaten
> Number of neighbours: Anzahl der Nachbarn
> Raster Training (Train on Raster):
> Min class value: kleinster Klassenwert
> Class value step size: Schrittgrofie
> Class level: Klassenebenen
> Training band: Trainingsraster
> Vektor Training (Train on Vectors):
> Feature bands: Bander, die fiir Trainingsvektoren verwendet wurden.
> Run: Prozess starten

Zudem gibt es den Spektralen Winkel Klassifikator “. Das Werkzeug Spectral Angle

Mapper Processor (nicht im GraphBuilder) weist einen Pixel einer Klasse zu, die den
kleinsten Winkel zur Trainingsklasse besitzt.

Das Werkzeug hat folgende Parameter:

> Im Reiter I/0 Parameters: Auswahl des Satellitenbildes, das eingelesen werden soll
und Speichername.

> Im Reiter SAM Parameters: Name eingeben
> Band Selections: mindestens zwei Bander auswahlen.
> Resampling parameters:

> Resample Type: falls Bander nicht die gleiche Auflésung haben, die
hochste oder niedrigste Auflosung wahlen.
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> Upsampling Method: wenn die hochste Auflosung gewadhlt ist, hier die
Methode auswdhlen.

> Downsampling Method: wenn die niedrigste Auflosung gewdhlt wird,
hier die Methode auswahlen.

> Spectrum Class Input: Einladen und Anpassung der Trainingsspektren

Im Reiter Thresholds: Anpassung der Schwellenwerte fiir jede Klasse. Je kleiner desto

unwahrscheinlicher das ein Pixel dieser Klasse zugeteilt wird, aber auch desto ge-
nauer das Ergebnis

Mit Run den Prozess starten
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Wie kann ich Daten exportieren, beispielsweise fiir QGIS?

Unter File » Export im Hauptmenii kann eine Satellitenszene in verschiedenen Formaten
gespeichert werden: BEMA-DIMAP, CSV, HDF-5, NetCDF/CF, GeoTIFF, GDAL writer oder JP2,
wobei GeoTIFF fiir die weitere Bearbeitung in einem GIS System zu empfehlen ist.

Daneben bietet SNAP auch die Mdoglichkeit unter Export > Other weitere Export-
moglichkeiten, unter anderem:

> Die Legende als Bild mit Colour Legend as Image oder als Farbpalette mit Colour
Palette as File abzuspeichern.

> Die aktuelle Ansicht mit view as Image als Bild (BMP, PNG, JPEG, TIFF oder GeoTIFF)
zu speichern.

> Sind die Daten in einem geographische Referenzsystem (oder werden zuvor umproji-
ziert), konnen sie auch als KMZ-Datei mit view as Google Earth KMZ gespeichert

werden und dann in Google Earth und dhnlichen Systemen gedéffnet werden.

B snae
File Edit View Analysis Layer Vector Raster Optical Radar Tools Window Help Abb' 65
Gep o0 GeP e Nl 5 B
& Open Product... ) ‘e % ﬁ o k™ Q ;_)’_ i \+ v .+ 9 04. ** o N (U B2 OO0
Reopen Product > F —
& Product Library [ — | [E (11 sentinel 2 MSI Natural Colors RGB X |
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Close All Products

Session

>
Projects >
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Weiterfiihrende Online-Quellen

FERN.Lern Webseite
https://fernlern.gfz-potsdam.de/lernen

FERN.Lern Youtube-Kanal
https://www.youtube.com/FernerkundunglLernen

Sentinel-2-Toolbox Tutorial der Hochschule Karlsruhe
https://www.h-ka.de/fileadmin/Hochschule_Karlsruhe_HKA/Bilder_FK-
IMM/IMM_GEO/UGM/Daten/UGM_SatBild-Tutorial o05-2021.pdf

Tutorial-Sammlung der ESA (englisch)
https://step.esa.int/main/doc/tutorials/

STEP Forum (englisch)
https://forum.step.esa.int/



https://fernlern.gfz-potsdam.de/lernen
https://www.youtube.com/FernerkundungLernen
https://www.h-ka.de/fileadmin/Hochschule_Karlsruhe_HKA/Bilder_FK-IMM/IMM_GEO/UGM/Daten/UGM_SatBild-Tutorial_05-2021.pdf
https://www.h-ka.de/fileadmin/Hochschule_Karlsruhe_HKA/Bilder_FK-IMM/IMM_GEO/UGM/Daten/UGM_SatBild-Tutorial_05-2021.pdf
https://forum.step.esa.int/
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